Rhino 7 Not Responding

Hello- the first thing to do is get the latest driver for your gpu from the nVidia website. Then, see if driving one monitor only helps at all.

  • Pascal

I tried searching for the latest driver it keeps coming back saying it has the latest one installed.

Have had 2 monitors running since this computer was built without issues until now.

Hi Wayne - are you asking Windows or the NVidia website about the latest driver? Windows will lie. I do not say you should not be able to run two monitors, I just would like to know if not running two monitors makes any difference…


Thank You Pascal,

I was just doing the standard driver update without going on the website and they had changed the name so it wouldn’t update automatically.

I have just completed the download and will try the system again on that model.

Wayne Buchholz.

Thank you I have done the website check and yes Windows did lie indeed name change from NVidia didn’t help.
Alas this was all in vain as it changed nothing below is the current system info.
Rhino still has a blue circle of death when trying any commands and usually pressing ESC key gets out of it however that gets very tedious when I am trying to work on details.

Any further suggestions would be appreciated, of note I will be sending the machine in to get a service from the Tech team next week.

Rhino 7 SR4 2021-3-19 (Rhino 7, 7.4.21078.01001, Git hash:master @ a432d22ab7f0f7b53d157d578278070c8bf6eff4)
License type: Commercial, build 2021-03-19
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P1000 (NVidia) Memory: 4GB, Driver date: 3-10-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.92
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-10-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21078.1001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”

Hi Wayne - is the hangup in particular files or any? Does it happen in detail views or model views, or both? Can you make it happen in a simple file, with just a few objects?


I tried a simple file of 512Kb and no issue there I went the file of 4Mb that I have been working on and the issue presented itself again, I have a model that was supplied by an architect of 235Mb and the issue didn’t present itself there.
Could the file I have be corrupt somehow?
I refence blocks so as to keep the file size down,


Hi Wayne - can you send us the 4MB one? Please make sure to save with all textures and send any external block reference files so we can reproduce the thing here - please send to tech@mcneel.com, with a link back here in your comments.


Forgive me how would I provide a link to that thanks.


Hi Wayne - I just mean the URL of this page -



Okay done sent thanks you Pascal.


@wlbdrafting - I do not see anything from you sop far on tech@mcneel.com.



The issue will be the size of the file and it can’t send that large maybe if I give you a Dropbox link to them.

Wayne Buchholz.


One of the files was too large to send via email so here they are in this link. https://www.dropbox.com/sh/2aegvqykw8zps72/AACpHkHSMailPXrfIvNZJiB7a?dl=0


Wayne Buchholz.

Hi Wayne -
I unzipped that file and opened “complete model.3dm”.
There are 21 other files in that zipped file and I assume that these are linked blocks.
Apart from these 21 files that are present, I get warnings about 40 other files that are missing.
One of the files that is present - “AWN 1200X1500 PUNCHED SHEET.3dm” is 46 MB but is a typical example of something that will bring your hardware to a halt. I opened just that file and got it to shade eventually but if you have any more that are like that, it’s no surprise that this model won’t be responding. You might want to try to extract rendermeshes for parts that you are not working on but just need displayed in your complete model and probably also want to tweak the display mesh settings to make sure those are as lightweight as possible.

Thanks Wim,
I was using ghosted mode mainly as I’m only providing detail drawings for those items in not sure what extract render meshes is I’ll look that up when I get back to my office.
The other files that it referred to are all only small items.
This is my first real attempt to do this work in Rhino I usually do this in Autocad in less than half the time it took me here.
The issue with the model only arose after I went back into the file and added the hand rails to all the balustrades.


Hi Wayne -

These are also typically items that will add large amounts of triangles to the scene - making the model slower to deal with.

To shade an object (in any “shaded” mode, ghosted included), Rhino needs to create a display mesh for that object. The Render mesh quality setting in Document Properties > Mesh control how dense that mesh will be for any new object. You can change this setting in an existing model for all new objects but you can also override the settings for any individual object in the object’s Properties panel.

When you only need to display parts in a large assembly where you are working on specific objects only, the “display-only” objects don’t necessarily need to include both the NURBS object and its mesh representation. Extracting the display mesh and deleting the NURBS object will, in some scenes, make it possible to handle larger or more complex models. Additionally, when several individual meshes share the same material, you can join them together into one (often disjoint) single mesh. If you can drastically reduce the amount of meshes, the model will be easier to deal with.


I am still having all sorts of issues with this program I can’t get my head around simple things like aligning one object to another or to a line the align tool won’t do what I need it too.

Next I want to sweep a Rhs tube along a curve in Autocad this would be done in 3 clicks in Rhino I have spent 3 hrs trying to find a way you tube and help menu searching and still nothing the attached file is the example I have been trying to complete.

Starting to think Rhino was a waste of money as it seems to be great if you don’t care about being accurate for fabrication detailing.

I should have spent the extra and got Ironcad it can do these operations simply and then can provide a detail drawing with measurements in an few clicks.

Wayne Buchholz.


A post was split to a new topic: ViewCapturetofile freezing Rhino

8 posts were merged into an existing topic: Rhino and Grasshopper stop responding