Rhino 7 not launching app

I just downloaded 90 day trial of Rhino7 and it opened the first time no problem. I saved my project and tried opening another file I needed to reference but it did not open. I restarted my laptop and now rhino does not open at all. I have a final soon and I have no idea what to do now.

call us at tech if you need an answer right now-
Technical support (206) 545-6877

if not, I’m assuming you are running a laptop, and it’s likely a hybrid graphics set up.

see this thread-

any chance you are on an asus machine?
see this:

1 Like

So my class just ended my professor recommended I redownload the program. I did that and it did the same thing only worked for the first time I opened it. It ended up working after having to redownload it a third time. Thank you

do us a favor and open rhino, run the systeminfo command and post the result here…

I’m concerned you have a hardware set up issue that need addressing so it does not come bite you late.

1 Like

Rhino 7 SR0 2020-11-9 (Rhino 7, 7.0.20314.03001, Git hash:master @ 9d1a3d02b292e00d3480c301d33f414d91acdcbd)
License type: Evaluation, build 2020-11-09
License details: Stand-Alone
Expires on: 2021-03-03

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Hybrid graphics system.
Primary display: Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 3-9-2020 (M-D-Y).
Primary OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 4GB, Driver date: 9-23-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.41

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-23-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Users\andre\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2019.11.5.949\Lumion\Rhino 6.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

great thanks!,

check out this thread and make sure you are set up to run on the nvidia as per the instructions (it may be already, but it’s worth checking)


1 Like

The first part was already in place. I completed the second part in the Nvidia control panel and I hope now I won’t have any problems.

please let us know if you do! we hate broken rhino’s as much as you do…

1 Like

Maybe this will help someone - I had a similar problem. Rhino 7 did not open, even in safe mode. No output, nothing. Reinstalling did not help. At the same time, I noticed that one of my games is complaining that vcomp140.dll is missing. So I repaired my VS2019 installation, uninstalled and installed Microsoft Visual C ++ 2015-2019 Redistributable (x86 and x64). Then Rhino started working again.

this is a common issue with old v6 and v7 installs- we updated our installer and most cases can be solved by downloading a new version of rhino from our downloads page.