Rhino 7 layercolour does not apply to some imported geometry

Hello there,

I recently noticed some issue in Rhino 7 (7.1.20343.9491) when importing Step geometry.
Some objects do not change their colour when selecting “layercolour” as “displaycolour”.

Rhino 7: imported geometry within the same stepfile, they both should be orange as the layer indicates:

Rhino 6 is not affected, after importing the geometry i can change the color according to the layercolour.
Another workaround: Saving the imported geometry (in Rhino 7) as Rhino 6 file and open it again with Rhino 7.

Reopend the Rhino 6 file in Rhino 7:

Is this a bug or is there a hidden importdialogue regarding the colour?

Unfortunately, I am not allowed to share the original step file.

Thank you! :slight_smile:

Test import srf wrong colour R7.3dm (53.9 KB)

Wow, that is completely weird - first time I have ever seen that on what looks like a normal, valid surface object. The edge color changes with the layer color, but the surface and isocurve color stays cyan. So far I have not been able to figure out why that is happening.

Copy-Pasting them into V6 and then back out from V6 to V7 fixes it… bizarre.

Hi All - Probably per-face color has been applied. I’ll take a look…

-Pascal

1 Like

Dang… That is going to take some getting used to. :confounded:

1 Like

I recently got caught out by this too, with some imported STEP files. As Pascal suggests, in my case at least it was due to per-face colours. There is a command (which escapes me and Rhino isn’t to hand) to remove them.

edit: the command is RemovePerFaceColors

Ahhh! Yes! _RemovePerFaceColors does the trick. :smiley:
So Rhino 7 is interpreting stepfiles differently than Rhino 6?

Rhino 6 seems to ignore (pre applied?) facecolors.

Hi all,
same behaviour here, same STEP imported geometry, same solution (thanks!) but one question:
would it be possible to add an option to the import dialogue window, to solve this “problem” at its origin?
Thank you really much for hte solution you proposed: I was getting nut with this color thing…

Got that, thanks.
RH-62903 Step Import: optionally ignore per face color

-Pascal

Hi Pascal,
Thanks to you, for opening your request for the “obscure command” checkbox :slight_smile:
I must say that, at least for me, that command WAS obscure! And I’m not exactly a beginner with Rhino.

Anyway, once again, this forum and your help taught me something new and solved a problem.

Have a nice day!