Rhino 7 ~ importing Solidworks files fails

Importing Solidworks files is failing in my Rhino 7 Mac (retail)

Rhino 6 Mac worked fine in this regard, but 7 claims to successfully import an SLDASM file … but displays nothing.

I wonder if anyone else experienced similar?

The same file works OK in V6?

One import attempt reproduced only a small part of the model. That was after the programme was clearly trying to work due to the time taken. When if fails, it reports a successful import almost immediately. It has been a year since I tried Version 6, but I remember it imported lots of SW files and well.

You need to try with the same file on both - it could be a file issue, not a general one… Are all the individual .sldprt files available and in the same folder as the .sldasm? Also, what version of SW? Rhino may not import the latest version, it’s often a version or two behind.

1 Like

Thanks; I don’t know which version of SW; the files are ex-Grab CAD. Yes could be a file issue rather than a general one, so I’ll try with other SLDASM examples.

PS. It was a few files with which there was a problem; others imported okay; I jumped too soon!