Rhino 7 - Hard to select gumball


I don’t know what happened lately, but I find the gumball really hard to select nowadays.
The usual clicking of the gumball simpy just deselects it, as if I’m clicking outside of it even tough I have my cursor on the gumball. I have to zoom in and out to find the “right” spot in order to use the gumball…

Am I the only one experiencing this? Quite annoying since it’s slowing my work-flow.

Thanks in advance!


In Rhino Options > Advanced, what is your pick box radius?
Mine is 7 and works fine on a 27" monitor running 2560 x 1440


Hi John,

Thank you for the fast reply!

I have checked it now and I’m also at a 7, using a 1920x1080px screen - should I increase or try decrease?

If yours was set to less than 7 and was a problem, is it working better now?

Hi! I’m not really following your question. Mine was already set to 7 as I’m experiencing the problem. I have tried to double the number och decrease the number but it doesn’t seem to do any difference - what am I doing wrong?

Hi again,

I am using rhino right now and it seems like the selection is now working as usual again.
Maybe it was a temporary bug or something. I’ll keep an eye on it if it happens again.

Thank you for the help!

Hi John,

I also am experiencing this issue on:

On many occasions, I can’t select the gumball elements. I tried changing the pick radius from 7, 15, 50 and no change.

The only way to overcome the problem is to zoom right into the object. I believe that it may have something to do with unit tolerance or units in general. E.g., when changing from mm to meters and dividing by 1000 to maintain scale, the object with dimensions in meters is much easier to select.
Perhaps this is because it has much smaller numbers for dimensions.

Downloaded the latest stable release (7.8.21196.5001, 2021-07-15), and the issue seams to have been resolved :slight_smile:


1 Like