Rhino 7 freezes/locks up when loading Grasshopper

Since this morning my Rhino 7 is not able to load Grasshopper.
Everytime it locks up when loading gets to 100% (see attached screenshot).
Yesterday it still worked fine and I haven’t doen anything in between.

I already tried repairing the program and installed the latest version (7.18). Also restarting my laptop didn’t help out.

Please tell me how tot fix this, thanks!

Problem might be similar to: Grasshopper wont load Rhino 6 and 7

Eventually this afternoon the Grasshopper canvas shows up, but it took way too long. This morning I waited for 1 hour without succes.

Today again the same problem. I’m waiting for almost 3 hours and still no result…

Please run the Rhino SystemInfo command before you try to load Grasshopper so we can see the computer resources Rhino sees.

Thanks

Rhino 7 SR19 2022-5-30 (Rhino 7, 7.19.22150.13001, Git hash:master @ b58c8f065217dbdd9b941fdb3577669355ae666b)
License type: Commercial, build 2022-05-30
License details: Cloud Zoo

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 1.3e+02Gb)

Computer platform: LAPTOP - Plugged in [80% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 2-18-2022 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro RTX 5000 with Max-Q Design (NVidia) Memory: 16GB, Driver date: 1-5-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.98
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-5-2022
Driver Version: 30.0.14.7298
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 16 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.19.22150.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.19.22150.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.19.22150.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.19.22150.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.19.22150.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.19.22150.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hoi Bram -

Does that mean that there are days where this isn’t a problem? If so, do you have any idea what might be different?
-wim

Eventually this afternoon the Grasshopper canvas shows up, but it took way too long. This morning I waited for 1 hour without succes

Like I said before, there was a day that it came to life after a very long period of waiting. But I guess that was a one time thing. After that I didn’t close Rhino so I could use it the next days as well, but that is not desirable…

Hi -
It’s a convoluted process, but you can use the GrasshopperLoadOneByOne command to prevent individual plug-ins from loading. This way, you can check if there is a specific plug-in that is locking up the loading process. I’d start by not loading 3rd party plug-ins and go from there.
-wim

1 Like

Excellent idea Wim

Hi Wim,

I tried the GrasshopperLoadOneByOne, but it freezes every time all plugins are loaded, doesn’t matter which plugin is loaded last.

I found myself a (temporary) fix by running the troubleshooter for compatibility: Make older apps or programs compatible with Windows 10

  1. In the search box on the taskbar, type the name of the program or app you want to troubleshoot.
  2. Select and hold (or right-click) it, and then select Open file location .
  3. Select and hold (or right-click) the program file, select Properties , and then select the Compatibility tab.
  4. Select Run compatibility troubleshooter .
  5. Select “Try with recommended settings”
  6. Click “Test program”

With this settings I am able to use Rhino/Grasshopper like before.
But after that it’s still not possible to start the program in a normal way.

Hi -

The point is to NOT load all plug-ins.
-wim

I understand. That is what I did, I excluded some (third party) plugins from loading but the result was the same.

Since your picture shows loading of the GHPython plug-in, have you tried to not load that as well?

image

-wim

Yes, than it just freezes on another one

Hi Bram -
Please use the instructions on this page to manually create a dump file when launching Grasshopper gets stuck. On the upload page, make sure to include the URL to this thread.
-wim

After saving the right compatibility settings for Rhino, the program did run as expected!
Thanks for all the help Wim! :slight_smile:

1 Like