Rhino 7 Feature: Display Performance Discussion

Here is the issue:

https://mcneel.myjetbrains.com/youtrack/issue/RH-61316

– Dale

Ah yes you’re right! Simply resolved by hiding the ‘Layout’ panel.
Look forward to the fix! Thanks for investigating.

RH-61316 is fixed in the latest BETA

Hi
I have a quite large model (3GB). I can’t share the model, but it include:
9610 block instances, 8813 points, 52327 curves, 6184 surfaces, 40768 polysurfaces, 6101 meshes, 18856 texts.

Especially the meshes are quite large, but are there any spesific reason for RH7 performing worse than RH6 on this kind of model? I guess it is a bit difficult question without sharing the model… (running on win10)

I get a bit over 8.5 FPS in RH6 and around 6 FPS in RH7.

The performance is in general worse on RH7. ex. I often use the section comand, it’s a quite heavy operation on this model, but RH6 manages it while RH7 most often crashes…

Just curious - if you hide all the texts, do you get better fps in V7?

Just tried hiding different objects. Seems like the blocks have the biggest effect on RH7.
bilde

I too just imported about 3300 blocks into a file I cannot share in V7, and got really poor performance (10-15fps). Performance especially tanked when I selected one of the huge block instances which showed the wireframe for all included objects.

However, saving the file as a V6 file instead, and then opening it in V6 made performance again smooth, even when selecting the blocks.

(Interestingly, the file went from 280mb to 400mb going from V7 to V6…)

Sorry for the not so useful data point… I also got light render bugs in V7 in that same file that do not appear in V6:

lighting

Unfortunately I can’t really make any optimizations without real models to base them on.

Does the performance improve when per-face colors are removed? A quicker way to do this to a model with blocks is to just open the V6’s .3dm in V7.

Per-face color display performance issue: https://mcneel.myjetbrains.com/youtrack/issue/RH-59196

That could be it. There are some face colors set on the model, and V6 doesn’t have any problems with performance after the import.

Unfortunately, the model is of our latest product just about to launch, and it’s almost the complete thing, so it’s far too sensitive to share at the moment.

Hi! First time poster here but a Rhino user since V1 back in 2001!
I’m experiencing big display performance issues, all of my files experience 10% to 80% fps drops in RH7.00 vs RH6.31, with the worse happening in shaded and rendered modes of texture-heavy interior models. Hiding blocks or text objects won’t make a difference.
Settings are the same in both Rhino versions and the issue is consistent on two different computers (all that I could test so far), an HP zbook360 with quadro P1000 and nvidia drivers dated apr 2020, and a windows workstation with quadro p2200 and drivers updated today. Both Win10 pro, fully updated.
Sorry for being generic, happy to help if any extra info is needed.
I just bought four upgrade licenses to RH7 and 2 full commercial ones, I seriously hope the issue is with me and not with the Rhino release as this renders the app completely unusable.

Feel free to send me a 3dm file and I’ll see what can be done.

Sent you a private message with a file. Thanks!

Thanks, I’ll try to look at it this week

@giorgiocassetta I’m looking at your model and from my early experiments it looks like edge softening is causing a big lag in display performance for your model. If I select all of the objects in the model and turn off edge softening, the display becomes much more responsive (and that is an understatement).

I’ll continue to investigate this issue to see what could be done when edge softening is applied to geometry, but possibly this hint will help you work with your models in the meantime.

This has been added to our bugtracker at
https://mcneel.myjetbrains.com/youtrack/issue/RH-61658

V6 doesn’t support per face colors at all. If you remove the per-face colors from your geometry in V7, you will probably have similar display performance for your geometry. Try the RemovePerFaceColors command

I’m looking at your model and from my early experiments it looks like edge softening is causing a big lag in display performance for your model. If I select all of the objects in the model and turn off edge softening, the display becomes much more responsive (and that is an understatement).

Thank you Steve.
I replicated the strategy here and yes, there is a performance improvement.
However, while I’m getting 16fps versus 1.7 on Rhino7 by removing edge softening, I’m also seeing 30fps vs 7.3 on Rhino 6 by doing the same.
So apparently Rhino 7 is still way slower than 6, except that it gets exponentially slower as the shaded geometry gets more complex.

Interesting enough, I realized that using the testmaxspeed command in rh6 will use 50% of my gpu (as per windows’ task manager),while rhino 7 will only use 16/17%.
Running the commands at once on both apps will not affect either’s performance.
Running them with the other app closed won’t change anything.
Maybe this is something that you could look into.