Rhino 7 crashing when in wire/shade/ghost view and zoomed in

I have just purchased rhino 7 but have been using rhino for years… when zooming in on objects in wireframe/shaded or ghosted views, to take a dimension for example or to examine a detail, the programme and the whole computer freezes completely. i am uisng windows 10 on a computer with 11th Gen Intel(R) Core™ i7-1165G7 @ 2.80GHz and 16gb ram.

this happens with mutliple different rhino files not just one specific file.


Run the Rhino command SystemInfo and post rhe results here.

many thanks for coming back on this…is the below what you need?

Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Commercial, build 2021-11-09
License details: Stand-Alone

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [81% battery remaining]

Standard graphics configuration.
Primary display and OpenGL: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 9-30-2021 (M-D-Y). OpenGL Ver: 4.6.0 - Build
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build
Driver Date: 9-30-2021
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Your computer has only the integrated graphics and does not satisfy the recommendations for Rhino 7.

Try turning off “Use accelerated hardware modes” if possible.

thank you. can you suggest the best way to do this. this computer was fine with rhino 6 so can i use this licence for rhino 6 instead?

Go to Options > View > Open GL and see if there is a toggle for “Use accelerated hardware modes”.

I assume you upgraded your Rhino 6 license to a Rhino 7 license. With that license you can run Rhino 6 and Rhino 7, but only on a single computer at a time. With the license configured as a Cloud Zoo license you can switch computers as often as you want.

thank you again. i was using another computer in the studio which had rhino 5 on for some time. i have just bought a rhino 7 licence for this new computer so i was not upgrading from a rhino 6 licence. so can i somehow reverse the rhino 7 licence to use rhino 6 i wonder assuming rhino 6 is less demanding vram wise??

i have toggled the gl setting to ‘openGL 3.3’ from ’ max openGL available’ . is this correct?