Rhino 7 crash when importing files on Mac M1 Max

Ir crashed every time when I tried to open a file, however, it seems fine if I create a new file in rhino. It only crashes while trying to import or opening an existing rhino file,

Here is the sum-ed up report:

Date/Time: 2022-09-21 01:54:36.104 +0800
End time: 2022-09-21 01:58:52.479 +0800
OS Version: macOS 13.0 (Build 22A5331f)
Architecture: arm64e
Report Version: 40
Incident Identifier: 2D539ED5-FC41-4B5B-9018-EE098D2AF4B8

Data Source: Stackshots
Shared Cache: 8CE2A7B5-011E-3C3B-A4B6-B68B4B74E9D5 slid base address 0x19fe54000, slide 0x1fe54000 (System Primary)
Shared Cache: 05F655A4-785C-345B-9364-11F38DECF1C5 slid base address 0x7ff906368000, slide 0x6368000 (Rosetta)
Shared Cache: E4ED3E51-C2E5-31C0-9448-AAFDAF819294 slid base address 0x188930000, slide 0x8930000 (DriverKit)

Command: Rhinoceros
Path: /Applications/Rhino 7.app/Contents/MacOS/Rhinoceros
Identifier: com.mcneel.rhinoceros.7
Version: 7.1 (7.1.20322.15002)
Is First Party: No
Architecture: x86_64 (translated)
Parent: launchd [1]
PID: 35273
Time Since Fork: 887s

Event: hang
Duration: 256.38s
Duration Sampled: 1.10s (process was unresponsive for 255 seconds before sampling)
Steps: 11 (100ms sampling interval)

Hardware model: MacBookPro18,4
Active cpus: 10
HW page size: 16384
VM page size: 16384

Time Since Boot: 265604s
Time Awake Since Boot: 116752s
Time Since Wake: 719s

Fan speed: 0 rpm
Total CPU Time: 1.748s (3.8G cycles, 7.8G instructions, 0.48c/i)
Advisory levels: Battery β†’ 2, User β†’ 2, ThermalPressure β†’ 0, Combined β†’ 2
Free disk space: 697.65 GB/926.35 GB, low space threshold 3072 MB
Low Power Mode: Enabled

Preferred User Language: en-SG, zh-Hant-SG
Country Code: SG
Keyboards: ABC
OS Cryptex File Extents: 325


Timeline format: stacks are sorted chronologically
Use -i and -heavy to re-report with count sorting

Please help, greatly appreicated. Cheers!

Hi Bao, It looks like you’re on 7.1, can you update to the latest and try again?

https://www.rhino3d.com/download/rhino-for-mac/7/latest

Thanks

1 Like

Hi Japhy:

Thanks for the speedy reply. I tried it on my computer and it works.

However, my college issued computer is using the older Rhino 7.1 on mac. Any chance you know how to fix that same issue?

Have your college update to the current version?
-wim

thanks Wim, ill try to ask them.