Rhino 7 crash at startup

Hi everybody!!!

After a few years using a evaluation version,i bought a commercial licence Rhino 7. I have installed it on my Macbook pro 2020 on , and also running it under Windows with VM-Ware ( because of a plugin D-Loft i need to create Dev-surfaces. Works like a dream… I use a Cloud Zoo to use it at home and at work. But i tried to install it on my work computer (MAC mini 6,1), installation and licence check works perfect. But when i try to open a file or template it imediately crashes…

Some help would be great!!!

Please run Rhino’s SystemInfo command on the Mac mini and post the results.
Generally Mac minis are inadequate for Rhino. They do not meet the System Requirements.

Dear Mr. Brock,

Thanks for your reply. How do i run Rhino’s Systeminfo when Rhino crashes immediately at startup? I have run Rhino 5 on this computer for a while and it worked fine…

This is the info of the Mac mini:


Modelnaam: Mac mini
Modelaanduiding: Macmini6,1
Processornaam: Dual-Core Intel Core i5
Processorsnelheid: 2,5 GHz
Aantal processors: 1
Totale aantal cores: 2
L2-cache (per core): 256 KB
L3-cache: 3 MB
Hyperthreading-technologie: Ingeschakeld
Geheugen: 16 GB
Opstart-ROM-versie: 424.
SMC-versie (systeem): 2.7f1
Serienummer (systeem): C07LJ27RDWYL
Hardware-UUID: 37097AA3-CE16-53B1-9FE7-192D173477AF

Intel HD Graphics 4000:

Chipsetmodel: Intel HD Graphics 4000
Type: GPU
Bus: Ingebouwd
VRAM (dynamisch, max.): 1536 MB
Fabrikant: Intel
Apparaatcode: 0x0166
Revisiecode: 0x0009
Metal: Ondersteund, functieset macOS GPUFamily1 v4

Hoi Remco -

As John wrote, that’s not really suitable to be using Rhino on. For Windows, we recommend that the minimum VRAM is 4 GB per screen used. I see that we don’t have that same recommendation on the Mac side but, well…

I’m not seeing any macOS information in this overview. Which version are you running? On the Mac side, bugs in the OpenGL implementation are typically fixed in newer versions of the OS. An immediate crash at start-up would indicate an issue with OpenGL. Make sure that you are on the latest macOS.

Process: Rhinoceros [3305]
Path: /Applications/Rhino 7.app/Contents/MacOS/Rhinoceros
Identifier: com.mcneel.rhinoceros.7
Version: 7.12 (7.12.21313.06342)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Rhinoceros [3305]
User ID: 501

Date/Time: 2021-11-23 12:19:23.917 +0100
OS Version: Mac OS X 10.15.7 (19H1519)
Report Version: 12

I could install Big Sur…?

Hi Remco -

I would say that’s worth a try, yes. I’d make a backup on the Time Machine just in case…