Rhino 7: command prompt loses focus when selecting geometry

Hi! Hope I’m posting this in the right part of the forum, or should it go to PaperCuts instead?

On Rhino 7, whenever I click away from the Command Prompt (e.g. to select some geometry) it loses its focus and any input I write on the keyboard (commands, for example) is ignored. If I click inside the Command Prompt again, my written commands appear as normal, but as soon as I click outside of it, the problem reappears. It’s not a big issue, but it can get quite annoying after modelling for a while.

Am I missing some options that I need to configure?

Cheers,

Pol

Duplicate post: Rhino 7: command prompt loses focus when selecting geometry

@polforeman You can delete your post by clicking on the three dots icon near Reply below the post, and then clicking on the trash can icon.

1 Like

Hi -
I’ve deleted the duplicate post, thanks @davidcockey!

Pol, could you please run the Rhino SystemInfo command and copy-paste the result here?
-wim

1 Like

Hi! Thanks for deleting the double post. I got a “server error” both times when posting so I assumed it hadn’t been posted at all. When I checked the newest posts there was nothing there.

Running Rhino in Safe Mode did not solve the problem.
Anyway, here is the SystemInfo:

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Kommerziell, build 2020-12-08
License details: Cloud Zoo

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 1-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 442.23
> Integrated acclerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-31-2020
Driver Version: 26.21.14.4223
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\Fologram for Rhino (468a328b-20d9-494b-b9e1-cbe9f827d3a2)\2020.2.2.0\6\Fologram.IO.Rhino3d.Win.rhp “Fologram for Rhino” 2020.2.2.0
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020” 1.0.6.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

This might be unrelated to the problem, but I realised that the command prompt also has no autocomplete.

The problem seems to be gone, after closing the Macro Editor panel and restarting Rhino (I had tried restarting Rhino before, that was not the issue). In case anyone reads this post looking for solutions.

Autocomplete is still not working, though.

@polforeman Is autocomplete turned on?
Options > Rhino Options > Appearance > Command prompt > Autocomplete commands

1 Like

It wasn’t! Works perfectly after turning it on.
Thank you so much!