Rhino 67 (title was too short, so here are more characters)

Hi,

I got some weird stuff, and I’d like to know if there is a way of fixing it without going through the complete uninstall-reinstall.

I’ve set up my computer so open evil sketchup files with Rhino7 (going through selecting the correct launcher, inside Rhino7 folder).
But here’s what happens

It has the Rhino6 logo, but says Rhino7, but opens Rhino6…

Anyone has also had to deal with this Rhino67 version?

Cheers,
Antoine

Right-click on a .skp file and choose “Open with…” (Ouvrir avec…)
Find Rhino V7 in the list
Make sure “Use this app for all .skp files” is checked
Click on the Rhino V7 icon.

The file should open in V7 and all future .skp’s will also be associated with V7.

Hey,

I already did all that, with the ‘use for all’ option as well…

Hi Antoine,

What happens if you click ‘Modifier…’, select the ‘More Apps’ option (sorry, don’t know what this is called in the French version of Windows) and then scroll right down until you can select ‘Look for another app on this pc’ and then navigate to the Rhino 7 > System folder and click on the Rhino.exe file, then try opening the .skp file?

Regards
Jeremy

If I remember correctly you can reset your default apps under Windows! Go into Settings > Default Applications (?) and there should be a reset option per file type or something similar.
To be sure I’d reboot after resetting!

Hi,
Thanks for the reply,
Sorry I guess my post isn’t clear, but that what I did. :slight_smile:
Rhino7 wasn’t directly available, so I when through the file explorer to select the correct Rhino version I want windows to use for .skps

I’m surprised Rhino wasn’t available from the list. Have you tried the same thing with another file type, such as .dwg? Do Rhino 6 and 7 appear in the available apps for that?

For dwg, both rhino are available, and selecting Rhino7 opens Rhino7 (as expected)

Could you post a .skp file which causes this problem (ideally a trivially small one)? - I don’t have any to experiment with.

Hi @antoinemaesantoine,

I downloaded a .skp file and can reproduce the problem (except mine opens Rhino 5).

The problem (and the reason that Windows doesn’t display the Rhino 6 and Rhino 7 options when you select Open With) is that when Rhino is installed it doesn’t register its capability to handle .skp files with Windows. It shows the options for .dwg files because it has registered its capability to handle those files.

I was able to make Rhino 7 work as the default app for .skp by hacking the registry, but I’m unwilling to share the details as I have no idea how complete a fix I created or what harmful side-effects I may have introduced. Better to let McNeel fix the installation process! (fyi @pascal)

Regards
Jeremy

1 Like

Oh waw, that’s more complicated that I thought !

Thank you for your time !
Hopefully it get fixed at some point…