Rhino 6 very slow

I have a 500mB model that has run at “reasonable” speed in Rhino 5 (once its loaded) but now is crawling to a slower and slower speed in Rhino 6. All I see at every move is A rotating blue donut and its driving me nuts !!

Is there a set of optimal settiings for Quaqro P4000 to get this version runing quicker and are there setgins in Rhino itself that I should consider to get this running faster.

Logikman

Rhino version & system spec

system spec:

Rhino 6 SR8 2018-8-18 (Rhino 6, 6.8.18230.16521,
Licence type: Commercial, build 2018-08-18

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Quadro P4000/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 390.77)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-23-2018
Driver Version: 23.21.13.9077
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

MACHINE SPEC:
|OS Name|Microsoft Windows 10 Pro|
|Version|10.0.17134 Build 17134|
|Processor|Intel® Core™ i7-8700K CPU @ 3.70GHz, 3696 Mhz, 6 Core(s), 12 Logical Processor(s)|
|BIOS Version/Date|American Megatrends Inc. 0610, 11/01/2018|
|Installed Physical Memory (RAM)|32.0 GB|
|Total Physical Memory|31.9 GB|
|Available Physical Memory|23.2 GB|
|Total Virtual Memory|36.7 GB|
|Available Virtual Memory|25.1 GB|
|Page File Space|4.75 GB|

Normally on architecture buildings that are good size it is the shadow casting that will slow things down. There is no question Rhino 6 pushes the graphics cards harder. There are a number of settings we can change to help the transition.

I would look at the standard upgrades first:

  1. Nvidia Driver. Newest one for your card is from October of 2018.
  2. Rhino 6.10 is a good update to get. You can go to the Help pulldown > Check for updates and turn up the frequency to Release candidate.
  3. The next part is to update the mesh settings so they are more efficient: https://wiki.mcneel.com/rhino/meshfaq
  4. Is this model full of textures? What display mode are you running in.

If this is a machine that has an Intel HD driver in it also, that can make a big difference. Normally check in Device manager for two Video adapters.

Once the updates are done, did the display get better?

Is this a Rhino model or a model read in from somewhere else?

Dear Scott

Apologies for not getting back to you sooner but I have been snowed under this past week.

Many thanks for your suggestions.

I will try these today and let you know how it goes.

In device manager only the NVidia Quattro P4000 shows under display adapters so I assume there is no Intel HD present or it has been disabled in the BIOS ?

There are no textures (as such) the model is mainly glass, metal and plastic.

I will try the mesh settings once I have updated the driver and upgraded to 6.1. the reason I was using the version I have is that I could not get the later versions of 6.0 to print correctly and there was an issue with images in panels (that I use for a logo block). It appeared on the screen in print preview but would not print ?

Catch up later.

Kind Regards

Lee A Roth

Technical Consultant

If you run in shaded mode, does the display go much faster?

What display mode are you running in exactly?