Rhino 6 - v6.28 & v6.29 hangs at splash screen

I have been running Rhino 6 version 6.28 which and I recently updated Rhino to the current version 6.29. This problem has come up on both versions.
Upon opening, the program hangs at the splash screen. This occurs whether or not I choose a file to open or not. It takes approximately 3-4 minutes to finally open. If I choose to open a file by selecting it, it takes the same amount of time which I am then greeted by the splash screen "would you like to save “untitled” rather than directly opening the file.
I updated my graphics cards (2x GTX 980TI Classified) which did not have an effect. I am running a Intel i7-4790K @4.38GHz and I have 32 GB Ram so this is not the problem. I uninstalled three different times, cleaned three different times and restarted and installed three different times with no success. The aforementioned problem also occurs in safe mode.
I did notice in my Task Manager that the program starts as a background process and I read somewhere that it could have something to do with thread priority or the such?
I have uninstalled and reinstalled all of the plugins in and out of safe mode without success. At this point I have run out of options.
Does anyone have information or a possible solution to this?
Greatly appreciated.

Hello -
Please run the SystemInfo command in Rhino and copy/paste the results here.


Thank you for getting back to me, here is my info log:

Rhino 6 SR29 2020-7-28 (Rhino 6, 6.29.20210.04411, Git hash:master @ 12abbebb020e24be0743d16d2eaf8be4cbd088f4)
License type: Commercial, build 2020-07-28
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-5HTM3JH

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 980 Ti (NVidia) Memory: 6GB, Driver date: 8-12-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.06

Secondary graphics devices.
DisplayLink USB Device (Unknown) Memory: 0MB, Driver date: 1-14-2019 (M-D-Y).
NVIDIA GeForce GTX 980 Ti (NVidia) Memory: 6GB, Driver date: 8-12-2020 (M-D-Y).
DisplayLink USB Device (Unknown) Memory: 0MB, Driver date: 1-14-2019 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-12-2020
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20210.4411
C:\Program Files\Geometry Gym\Rhino3d\BullAnt.rhp “bullant”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20210.4411
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\MyApp\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.3.1.650\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20210.4411
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20210.4411
C:\Users\MyApp\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\OctaneRenderForRhino (f109bd23-4cf3-4c0b-9f83-06be474b0152)\2019.1.4.115\RHI Installer 6\Rhino 6.0\x64\OctaneRenderForRhino.rhp “OctaneRenderForRhino” 2019.1.4.115
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Users\MyApp\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2018.8.24.259\SectionTools.rhp “SectionTools”

Hello - see if disabling Octane makes any difference - Options > PLugIns page, uncheck the ‘Enabled’ box for Octane, close and re-open Rhino… any better?


No good. Still heavy load time.

Hello - what does the splash screen say at the lower left when it slows down?


Rhino is starting…

One last thing… I see another plug-in to disable, BullAnt, but I am not very confident that will make the difference - @brian - do you have an idea? Rhino takes several minutes to start up.


I tried disabling that too, When it finally does load, 3-4 minutes later, everything is normal again. I do not have any problem operating in my usual fashion.
Also, once inside of Rhino, opening new files both populated and from scratch work just fine.

Another thing to try is this:

  1. Close Rhino
  2. Open the Registry editor (From the Start menu, type RegEdit, then press Enter)
  3. Browse to HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\
  4. Rename the 6.0 folder to 6.0-backup
  5. Start Rhino

Does it start faster? If so, there’s probably a setting in the registry that is slowing things down.

It does start faster. Thank you. Is it a bug or something else?

as an aside, this thing may need a new driver… the date being unknown tells me there is a driver issue of some sort. we don’t like driver issues with display stuff…

Can you please send me in a DM the contents of both your 6.0-backup and 6.0 folders? That will help me see which settings might be slowing down startup for you.