Rhino 6 start up and freez issues macOS Catalina 10.15.6

Any solution to this yet?

Im running a iMac (Retina 5K, 27-inch, 2017) with latest software and latest Rhino 6.

The very first start of the day works fine but if I want to open a second file or shut the first file down and want open a second file it freezes. I see the file preview but it never opens. If I shut Rhino down completely and try open the second file the icon just bounces in the dock but never opens. Getting pretty frustrating. Only thing I can do is restart the mac completely. This all started after the latest ‘update’ from Rhino.

I tried erasing the .plist file etc. Didn;t do it for me.

“I tried erasing the .plist file etc. Didn;t do it for me.”

Does that mean you successfully deleted the PLIST file or that failed too?
Deleting the PLIST is what I would do.

This has to be something local and unique to your setup.
This is not a common issue.


I managed to delete it but the issue remained right after it. Although today it seems better?!? I also don;t have this on my apple laptop. Will keep monitoring and keep you updated.