Rhino 6 SR22 and rhino 7 wip Lag bug

Sorry, I probably overreacted, but hey, the Text Property Panel is clumsy since the release of v6. This not a scoop.
We are now by SR27, and this is still not working 100% fine.

I fully understand you’re probably more focused on adding nice features on the V7 right now, but Jesus, if some simple tasks like editing annotation objects without having to wait 5 seconds between each action still won’t work, please put a bit more effort and willingness, and fix that damn Annotation Object / Text Panel once and for all.

Just telling the clients to ‘…solve that problem first’ as they are trying to help to identify the problem is IMHO rude and no proof of cooperation on your side. If you’ve bothered reading my previous post, you would have find out why I’m using the safe mode. But anyway…

So here again, I disabled a few fancy plugins, ran Rhino in standard mode and here is the result:

Rhino 6 SR28 2020-6-23 (Rhino 6, 6.28.20175.14591, Git hash:master @ 9ddbd1399e001a3eae701470332b5379477fa7d6)
License type: Commercial, build 2020-06-23
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name:

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro P2000 (NVidia) Memory: 5GB, Driver date: 6-21-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.48

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 6-21-2020
Driver Version: 27.21.14.5148
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 5 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.28.20175.14591
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

And the behavior observed:

  • left font: ‘Arial’
  • right font: ‘DejaVu Sans Condensed’

The file is here: __LagTextObject.3dm (52.7 KB)

The simple action of selecting the TextObject drains 50% of my CPU during several seconds.

If this is suppose to be the expected behavior, ok then, but do not expect me to encourage my company to switch to v7 if such basic stuff isn’t handled properly until then (because BTW, the similar bug currently occurs in Rhino WIP).

1 Like

I can see the lag here with the file above, but that may be because I do not have the font for the text block on the right installed (DejaVu Sans Condensed). Actually, the lag occurs here when deselecting the text, not selecting it - maybe 5 seconds or so. Obviously, if I change it to something else, the lag disappears. Otherwise, the lag may be due to Rhino looking for the missing font every time you select the text block and not finding it (here at least).

Hi,

Any improvements on this topic?

I tested to disable spell check as adviced here (Rhino 6, 6.30.20266.14531):

Moreover, on file start, the text panel is also not display properly:

Is there any hope this issue will be fixed one day?

Hi jeff, in the past I had another problem about delay on the text panel… it was like the dimension of the panel was putting Rhino interface in a resize loop.
I solved changing the column size so the text panel was fully visible… after that it seemed fixed…

Hi everyone,

I have the same problem as @jeffoulet , when selecting a text or dimension I have a lag of 1-2 seconds and it’s hard to work whit this handicap. It happens when properties are open, and do not happen if you select or move text without properties on. I’ve tried to modify the text/dim double clicking and don’t happens, so it’s seems to be something about properties.
In rhino 6 the lag was about 1 sec or less but on rhino 7 it’s worse…
I’ve changed the style and font to check but it’s still happening.

Thanks

Same problem here as well. Happens when properties are open and do not happen if you select or move text without properties on. And after I updated my windows 10 to the latest version, it causes me to have to lag on my windows UI when I drag them. This only happened when I open the rhino, everything goes back to normal when I closed the rhino. So it’s definitely the rhino’s fault.

Pretty sure it’s not my performance issue, since I am using 5900x + 3080 with 32GB GDDR4 memory

Exactly the same here. Brand new install of Rhino 7 (latest). No plugins. Massive lag when trying to edit annotation with the properties dialogue open. It is really problematic when I am doing lots of 2D documentation etc. Is there anyone working on this?
Cheers. All drivers updates as well. Please help!

1 Like

Same exact text / annotation lag problem as rupertenberg above. Latest install of Rhino 7 with no plugins (in fact, it’s the Evaluation version). Every time I click on an annotation or text to work with it, there’s a 1-to-3 second delay. Doesn’t matter which font, or whether it’s a text or annotation, or what I’m trying to do with it. I’m working on a set of blueprints right now and I’m just cursing up a storm…this is taking me like 3x as long, and it’s so. much. effort. In fact, it’s so unworkable, I am seriously thinking I probably won’t be able to upgrade from Rhino 5 to Rhino 7, which is crazy. I’ve been using Rhino since 1.0, and I’m usually psyched to upgrade. I guess I’ll wait til Rhino 8?

2 Likes

Hello - for now, please make sure Properties is not open or not on top in the pile of panels on the right.

-Pascal

Thanks Pascal, keeping the Properties tab in back is working and is a reasonable workaround for now :slight_smile:

Hi Pascal,
I hope something can be done because I use a lot text, dimensions and named objects. Having Properties Panel closed it’s not an option and make my workflow veeeeery slow.
I´v tried with some possible solutions:

But nothing has changed.

Thanks for reading and hope something can be done.

PD: In the last version of rhino (Version 7 SR5 (7.5.21100.3001, 2021-04-10)Comercial ) changing layer colors has also lag, that’s something new.