Rhino 6 SR1/SR2 randomly crashes while Grasshopper is running (not SR0)

Thanks for sending in the report. We searched for the email address you use here in the forum but didn’t find any crash reports. Did you send them in from another email address? There’s a field in the crash reporter where you enter your email address.

I was having intermitent connection at the time maybe they were not sent at all. :grimacing:
I rolled back to SR0 and the problems are gone so far maybe this weekend I can give it try again.

Oops I have just discovered the memory dumps at %userprofile%\AppData\Local\CrashDumps
Do they contain any personal data? Can I directly post them here?

maybe better to post them with rhino3d.com/upload - copy the link to this discussion so we know to what the upload belongs to

Done!

Hi LowEndSilicon,

Is there any chance we could get the Grasshopper file you’re using when you get the crashes? The crash looks like it’s in display code but the code in question looks sounds ( the crash is actually an unhandled exception in the c runtime). We like to try repeating your crash here, in a debugger.

Tim

Hi @LowEndSilicon,

This has been reported before:

https://mcneel.myjetbrains.com/youtrack/issue/RH-44109

We’re looking to find a way to repeat it here…

Thanks,

– Dale

Sadly the crashes took place before I could save the Grasshopper files. :neutral_face:

I’ve had what seems to be the same problem several times, I have sent the crash report with the .3dm file attached.

–edit–
When the last crash happened, I was trying to put back the camera center to the axis origin in perspective viewport.

I rencently upgraded to SR2 and the chrash still takes place (only when grasshopper is running). This time it crashed when I was tweaking the material parameters of custom preview geometry. Other times it crashes just by placing the first component when everything else is empty. Rolling back to SR0 is the only fix for me apparently.

Another hang, this time while running Grasshopper and with faulting module VCRUNTIME140.dll. The crash report was filled with the name LowEndSilicon. Definitely you have introduced a serious stability bug in both SR1 and SR2.

Any news on this topic? I would like to be able to use the latest SR as it provides some other fixes.

Hi,
My colleague had a problem with Grasshopper 1.0 crashes and the problem was solved by strictly using only GH plugins updated for GH1.0 / Rhino 6. In his case it was outdated Elefront causing all the crashes.

Cheers
Jonas

There is an SR3 release candidate that should fix this crash.

I do not think this is the case as I tried SR0 and SR1/SR2 with the exact same Grasshopper plug-ins and the crash does not take place with SR0.

I used to try new releases hopping they would fix the crash, but I am tired of losing files. I will not update or test new releases unless the changelog refers to a fix of this specific crash. There is one fix for a Grasshopper crash but sometimes it is just dropping the first component to the canvas and it immediately freezes.

I worked on this crash. I was never able to repeat it on my computer, but the changes I made should mitigate this crash. I can’t guarantee that what is causing your system to crash is the exact same crash reported by others, but it was a pretty high frequency crash that affected a lot of people.

Would it be helpful if I uploaded my Grasshopper folder?

No; the crash occurred inside of Grasshopper itself while setting up previews of planes. You would need to update to the SR3 release candidate to see a difference.

I will give it a try then.

1 Like