Rhino 6 SplitMeshWithCurve Bug! Does not work!


(Eric Martin) #1

Hello fellow Rhino people! I just upgraded to Rhino 6 and I have already found a few annoying bugs that worked great in Rhino 5 but not in 6. Not sure if this is the right place to report it, let me know if i should report somewhere else. Not sure how fast the dev team is on fixing stuff. I am a newb in the forums and just want to help report what i find because i use Rhino a lot.

In Rhino 6 when i do the command SplitMeshWithCurve the mesh just disappears. If i copy the same thing and paste it into Rhino 5 then it splits like it is suppose to.

Pic of what im splitting…

Pic of Rhino 5 working…

Here is the file im working on.
Signal Hills.3dm (6.6 MB)


(Kyle Houchens) #2

I’m getting crap results in both version here as well- however:

  1. you are extruding a curve that should be rebuilt in sections. having a linear straight line with 1000 points is just bad modeling practice and will always make you life harder. don’t do that…

  2. you are meshing an extrusion which is forcing your mesh to have very long triangles- explode your extrusion 1st, to convert to a surface, then mesh the surface, you will get a much more even mesh without any stretched polygons. (long triangles are typically “bad”)

  3. if you back up, and extrude the base curve, (extrusion) then explode the extrusion to convert to surface, and then join (polysurface) then split using nurbs tools, the split happens perfectly… you can then mesh the result with really nice outcome.

all that said, clearly the mesh tools still suck and need to get fixed. I’ll write this up and hand over to the developers.


(Eric Martin) #3

Cool thanks for the advice! I tried your way and it works. Thanks!