Rhino 6 slow with pasting even small objects

Is saving a file with pictures when “Save Textures” is enabled comparably slow?


If I were to guess I’d say you have either huge resolution pictures, or very many of them. The saving with “Save Textures” checked would be as slow - in both cases the textures are essentially packed into the file/clipboard

Yes, saving the file is relatively slow. Which makes sense, as like you said the images are packaged. I find it odd that copying to the clipboard when I am only copying a line in the file (and not an actual image) is also slow, however. Maybe you could enlighten me as to why this would be?

And while I do have a number of images in the file, they’re all JPGs roughly ~2MB each. Correct me if I’m wrong, but having 7 of these in the file shouldn’t be too taxing, should it?

I did some more sleuthing, and it appears that the images are much larger than I thought? Yes, they are high-res.

In the attached screenshot, could you clarify what the difference between “File size” and “Image size” are? File size is the size I know from Windows Explorer. Image size must be the unpacked/scaled image? I would assume if I had 7 images all at the ~150MB seen in the screenshot, that would definitely slow things down.

Perhaps as a follow up question - is there a way to easily reduce this size without me having to go into an image editor and scale them? I’ve been tracing sketches so while I do need some level of quality, I don’t need 150MB of quality!

Indeed image size is the final size of the image in memory.

You probably could get the image size down by saving as a greyscale (8bit) image. That cuts down do a third of image size.

I think someone with more intimate knowledge of clipboard copy/paste needs to look at this, since it looks like all materials/textures are traveling along with the clipboard, even though they aren’t necessarily used. @andy, @dale, who would be the best person to have a look at this?

@arulewich if you really want to cut down on image size you could convert it to a black-and-white (1bit) image, save as png. You should do that only if you don’t care about anti-aliasing, though.

Good suggestions, and I’ll definitely do these to keep working in the meanwhile. Clearly the images are much larger in memory than I need them.

I’m still curious to know why all the textures are being carried into the clipboard regardless of what I’m actually copying, however. If anyone could enlighten as to this, I’d love to know!

Thanks again

Hi @arulewich,

If you open a new file and CopyToClipboard and Paste, it is slow?

A Paste operation is equivalent to an Import operation.

If you Export selected objects, which is what CopyToClipboard does, and then import the file you just exported, is it slow? I would expect it to be in you large model.

– Dale

@dale when putting a simple box without materials into the clipboard the action will be slow when there are materials with huge textures in, even though the box has no materials assigned. You can see by first doing ctlr+C in scene with just box. Instant action. Now add a couple of Pictures with huge resolution (say 6kx6k 24bit pngs). Now select the box that has no materials and copy to clipboard…

Exactly. The speed of the CopyToClipboard command seems to be directly tied to how large the total amount of textures in the file is. I don’t know if this is specifically Picture textures or just high-res textures in general.

For me, CopyToClipboard is only slow if there are a number of high-res Pictures in the file, regardless of whether they are actually included in the copied geometry or not. They simply need to be in the file for all CopyToClipboard commands to slow. Paste does not have this problem.

As to your Import/Export question Dale, how fast the Export command runs is entirely dependent on whether I have the “Save Textures” checkbox checked. If it’s checked, very slow. If it isn’t, no speed problems at all (which makes sense, as the Save operation functions similarly).

@nathanletwory , @dale - thanks for digging into it…- has this been buggified by anyone?



@pascal not by me. All yours (:

This happended to me today. Noticed copying to clipboard was extremely slow even for simple objects. It started happening when I added a picture Frame to the file.

Hi all, is there any development on this issue? This really slows down the workflow and wasn’t an issue with Rhino 5, so i guess some sort of solution should be possible.

Hi Julian - This issue is currently on the Rhino 7 list of things to fix.
Perhaps @JohnM can provide more background.

Does this mean that if R7 is released in 3 years or so (R6 took a long time too), we’ll have to do with slow copying and pasting till then?? Why not solve this in R6 in an update? I mean, really…

1 Like

I’m having the same problem as well. Saving to a cloud directory that’s synced to a local directory, plus high-res images in the file. Is there anything that can be done fasten the workflow? best practice advice?

Rhino 6 SR17 2019-8-23 (Rhino 6, 6.17.19235.15041, Git hash:master @ 06b69c5cc21d880aa793a5a7cfd454a66f6213bb)
License type: Educational Lab License, build 2019-08-23
License details: LAN Zoo Network Node

Windows 10.0 SR0.0 or greater (Physical RAM: 64Gb)
Machine name: 600SZ1G3E8S5-17

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro M2000M (NVidia) Memory: 4GB, Driver date: 5-5-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 430.64

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-5-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2019 for R6\RhinoCAM 2019 For Rhino6.0.rhp “RhinoCAM 2019 - The cutting edge CAM plug-in for Rhino 6.0 from MecSoft Corporation”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
D:\GDrive_BE-CU\Columbia University\GSAPP\DESIGN RESOURCES\SOFTWARE RESOURCES\Rhino\Grasshopper\Plug-Ins\elefront400\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\be2263\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.12.17.906\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\import_ACAD.rhp “AutoCAD file import: import_ACAD”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\RhinoCAM 2019 for R6\RhinoArt1FileExporter For Rhino6.0.rhp “RhinoArt1FileExporter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V6\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Rhino 6\Plug-ins\BlockEdit.rhp “BlockEdit” 6.17.19235.15041
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”

Hi - I take it that you refer to the issue with slow copy-paste? From what I understand, copying with the gumball will be faster because it doesn’t use the Windows clipboard.

Yes, correct I’m having the same slow copy-paste issue. That’s correct gumball copying is faster but if I remove embedded the images from the file would that help at all? Thanks.

Hi - yes, removing all images that are used in the file will also speed things up.

1 Like

Thanks for the tips, materials or rather heavy image files seems to be the cause of this problem fyi, at least on my end.