Rhino 6 several bugs

Dear Community,

as a ‘Professional’ Rhino users i would like to inform about some imperfections i have found after updating to Rhino 6.

Unfortunately our company is forced to use rhino 5 instead as rhino 6 lacks mostly for our daily use.

Here are some glitches we experienced in the first moments of usage, working in 2d drawings:

  1. Blocks which contain texts go insane after scaling, the text height will appear random scale after leaving the block editor.

  2. Opening an Rhino 5 drawing in Rhino 6 will make leader/dimension text alignments go random.

  3. If a block contains a leader or dimension which will be mirrored, it will mirror the text. In rhino 5 texts / dimensions dit not mirror.

  4. If a vertical dimension is mirrored horizontally, the text alignment becomes mirrored, also as the displayed text.

  5. The overall look of the wireframe mode is different than rhino 5, the lines are slightly thicker, it becomes difficult to distinct multiple lines close to each other when not fully zoomed in.

  6. There is slight delay when selecting several curves, i have updated my drivers but it makes no difference.

  7. Opening/saving a file takes longer versus Rhino 5. It looks like Rhino is somehow struggeling.

  8. The blockmanager works fine, however the import block commando does make a difference between capitals and lower case letters. the order of blocks is like ABCDEabcde

It seems there are lots of benefits in Rhino 6 towards Rhino 5. But for us as a company which has to rely on Rhino we have to stick to the foolproof Rhino 5 because of some minor isues.

I hope these are just bugs and will be gone on the next update.

Looking forward to reveive any feedback about these items.


Hello - Any simple examples you can provide would be helpful - I suspect the change in how annotation styles are handling things may be underlying a lot of what you’re seeing, but it would be useful to have examples- my quick test with both embedded and linked blocks seemed OK here for example, so there must be a combination of factors I’m not hitting yet.

thanks for the feedback,


I’ve had a bunch of problems with annotations, you can see here , I too am hoping some of these nasty little gremlins get cleared up soon :slight_smile:

1 Like

This has been addressed through a application setting. There are so many different monitor configurations out there nowadays that it is hard to figure out what the exact correct thickness is to use when drawing in wireframe.

The easiest way to adjust the wire thickness is through the TestWireThicknessScale command that is discussed here:

Please give the SR3 release candidate a try if you are willing. This is how we can figure out if we are making any improvements for your specific issues. We’ve made quite a number of changes recently with respect to text. We will continue to ship service releases every month with fixes.

1 Like

Dear Pascal,

Thank you for your reply!

I wil try give an example.

open a fresh rhino> type some text and make this a block> scale this block, for example 5 times> open this block and close it again, now here is where the problem starts, and the text wil scale huge out of proportion.

Hope this will help!

Dear Steve,

thank you for your reply!

I did found the TestWireThicknessScale commando, this will do. But lines with an different linetype than continous (like dashed an hidden for example) are not affected!

Although i will keep an eye on the release candidates and updates! and will give it a try!

Items 1-4 above all seem related.

https://mcneel.myjetbrains.com/youtrack/issue/RH-45146 (you won’t have access to that YT issue since it come in through private email communication and is therefore considered private). This one bug may have manifested itself in different ways and may have been many of the mentioned bugs in the discourse post. SR5 is not available yet, but we should see an initial release candidate for it in about two weeks. If you need access to this service release before then, let me know and I’ll see what we can do.

This is currently solved through the TestWireThicknessScale command. We’ll improve this in the future, but that command should let you adjust thicknesses to your preferences.

I’ll need a sample or some more information on how to repeat this.

How much longer? I’ve heard reports of Rhino 6 taking longer to save, but I’m not really familiar with this issue or how bad it is.

@JohnM can you take a look at this? I don’t know if it should be filed as a bug yet or if there is something that changed in the UI to allow for different sorting styles.

@stevebaer I did some testing and it looks like it is using a case sensitive sort in V6 and it was not in V5, I would say it is a bug. Looking at the code to see how it is sorting, I know there is a core function you can call to get a sorted list of table objects and I don’t know if that changed. I’m assuming we are talking about the combo box at the top of the insert dialog box.

Thanks John, can you please log the bug.

Reported as RH-45522. I went ahead and just fixed it so the fix will be in next weeks build.

RH-45522 is fixed in the latest Service Release Candidate

“You have no permissions to view this page”

Weird, it’s visible to all users as far as I can see. Are you logged in?

I can see it now. I was logged in when I could not see it.

2 posts were split to a new topic: Name conflict warning glitch