Rhino 6 Randomly reseting all Settings to default

unhandled
(Info) #1

Sometimes Rhino is reseting all settings back to default, Removing custom views, resetting all tool to defaults. It is happen while Rhino is running, not while start a new instant

This is really really frustrating and i dont find any error why this is happen.

Where could i start searching.

(Pascal Golay) #2

Hello -

Do you mean named views are deleted?
Is only one Rhino running? Can you please post the results from the Rhino command SystemInfo?

-Pascal

(Info) #3

I mean the Display Modes https://wiki.mcneel.com/rhino/6/advanceddisplay.

But settings like default file on rhino startup and tooldefaults are reseted too.

I have allways 3-6 RinoInstants running, but very short projects with ram-footprint about 200mb maximum

Systeminfo:

Rhino 6 SR14 2019-4-28 (Rhino 6, 6.14.19118.15561, Git hash:master @ 8f0a84997c310a7ec1a42cf2704da8daa33e3e21)
License type: Kommerziell, Build 2019-04-28
License details: Cloud Zoo. In use by: Martin ()

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: PC-FELIX

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 1060 6GB (NVidia) Memory: 6GB, Driver date: 3-17-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 419.67

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-17-2019
Driver Version: 25.21.14.1967
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\Felix Kirchhof\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2017.11.17.800\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.14.19118.15561
C:\Users\Felix Kirchhof\Nextcloud\JewelryToolbox.rhp “JewelryToolbox” 1.1.0.1
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19118.15561
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

(Pascal Golay) #4

Hello -

Does any of the instances crash when this happens?

the first thing I see is that you have a minimal amount of RAM for 3-6 instances of Rhino running 200MB files - I would start there - get at least twice that amount.

(Info) #5

Sorry misunderstanding. The files are between 500kb and 5mb, the used RAM per instance is about 200MB maximum. So there is normaly no RAM shortage.

No, no instance is crashing.

(Pascal Golay) #6

@JohnM - seems like Settings is being replaced 'on the fly ? Any ideas how this could happen? I’m guessing it has to do with multiple instances open but…

-Pascal

(John Morse) #7

It sounds more like a Rhino is updating and extracting new toolbars and such “tooldefaults are reseted too”. I wonder if a new Rhino is opened on a new day after a update has been installed. Do you see a window pop-up in the top left corner saying Rhino is installing new toolbars when this happens?

(Info) #8

Normally i close all Instances of Rhino bevor installing a update. I couldn´t say if a update was bevor by the older resets but by the last one there was no pop-up. The last update was a few days bevor but i defently have had closed all instances bevor apply the update.

The last reset was on the fly while i was working in one instance and the other 3-4 was idle in the background. But all have been reseted.

It isnt happend often, 3-4x since the release from rhino6. Never happend in rhino5