Rhino 6 Projecting Arc onto Compound Surface


(Drybovich) #1

I’m having an issue projecting an arc onto a polysurface with compound curvature. I’ve tried the custom, view, and CPlane projection options, but they all seem to have the same result. I’ve uploadedProjection Issue.3dm (123.6 KB)
the file. I’m trying to get this to work in the Top view.

Thank You.


(Pascal Golay) #2

Hello - what is the problem that you encounter? Project seems to work OK here. The arc is pretty close to the surface as is, .19 away.

-Pascal


(Drybovich) #3

Hi Pascal,

The arc is being projected, but not in the direction I’d like it to be. When i try to project it in the top view straight down, I get a new line that seems to be random, or maybe it’s perpendicular to the original arc plane…? Here’s the file updated with the arc before and after projection. The red line is the result:
Projection Issue b&a.3dm (124.0 KB)

Thank You


(Pascal Golay) #4

Ah, OK - there was a bug fixed that looks a lot like this. I’ll attach my projection…

Projection Issue b&a_PG.3dm (103.3 KB)

FYI: https://mcneel.myjetbrains.com/youtrack/issue/RH-45014

-Pascal


(Drybovich) #5

Thanks. How do I fix the bug? It’s telling me I’m updated.


(Wim Dekeyser) #6

That depends a bit on your settings. You probably have your update frequency set to either “Service Release” or “Service Release Candidate”. The current SR candidates are for 6.4. This bug is fixed in 6.5, so unless you are installing “daily releases”, this will come to your system in a short while…


#7

I’m having the same problem. I’m showing Version 6 (6.4.18107.1041, 04/17/2018)

I’m not even showing an “daily releases” option in my Update frequency


(Drybovich) #8

Hi Tim,

There are still a lot of bugs they’re working out in Rhino 6. The only real way I’ve found to deal with them is to save the file as a Rhino 5 file and work on the project in Rhino 5.


#9

Yea that’s why we upgraded to Rhino 6… so we can keep working in Rhino 5.:wink:


(Drybovich) #10

The $100 you save in upgrading early they get back from you in finding all of the bugs


#11

New problem!
Since I can’t project in Rhino 6, I took Drybovich’s suggestion and saved as a Rhino 5 file. But now my Rhino 5 64-bit .exe file has disappeared. I’ve done a system search and it nowhere to be found! Did the upgrade to Rhino6 delete it? Any help?

"C:\Program Files\Rhinoceros 5.0 (64-bit)\System\Rhino.exe"


#12

Capture


(Pascal Golay) #13

Hello - -hmmm- no, installing V6 should not touch the V5 installation, you can run both side by side.

-Pascal


#14

It looks like the 32-bit version is still working. But the 64-bit has always been my default. I would sure like to continue using the 64-bit version. Any ideas to were it went?


(Pascal Golay) #15

Hi Tim - weird… I have no idea… but you can always re-install it from the latest installer here:

https://www.rhino3d.com/download/rhino/5/latest

install using the same V5 key you used previously.

-Pascal


#16

For future reference, I used REPAIR in the Control Panel / Programs and Features. It reinstalled the Rhino.exe file in Rhinoceros 5.0 (64-bit). It seems to be fine now.


#17

From what I understand a fix for the project bug is in a new version 6.5. I’ve been waiting for this upgrade since April 24th. Has it been released? I’m still having issues projecting and moving back and forth for Rhino 5 and 6 is very frustrating.


(Wim Dekeyser) #18

The current release is still 6.3 but we are close to having a final 6.4. After that point, 6.5 Release Candidates will be available.