Rhino 6 Performance Issues

Can you try the following:

  1. Close Rhino.
  2. Delete the following folder: %TEMP%\McNeel\Rhino\V6.
  3. Go to %APPDATA%\McNeel\Rhinoceros.
  4. Rename the 6.0 folder to 6.0.backup.
  5. Start Rhino and see if it helps.

-David

It did not help: _testmaxspeed 70,53 sec

-Joe

Hello, I am browsing everything connected to Rhino to find out, where might be the problem. I have found out, that Rhino development kit has its own instalation:

When I have reinstalled whole RH 6, I have certainly did not uninstal Rhino RDK. I am not sure, if RDK somehow manages rendered mode or not, but I thought I’ll give it a go. I was thinking I’ll download instaler and reinstal RDK aswell, but I did not find any instalation file on mcneel page.

Should I try something out? I do not want to screw it more, than it is.

Hi Jan -

Could you try the following?

  1. Uninstall Rhino 6
  2. Delete HKEY_LOCAL_MACHINE\Software\McNeel\Rhinoceros\6.0
  3. Delete HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\6.0
  4. Delete %appdata%\mcneel\rhinoceros\6.0
  5. Install Rhino 6

(Note that deleting the %appdata%\mcneel\rhinoceros\6.0 folder will delete any customizations that you have made - you can make a backup of this folder if there’s anything that you need to keep).
-wim

Reinstal helped a little, but it is long way from good. After reinstall _Testmaxspeed 42,19 sec, after update to newest version 44,93 sec… You did _testmaxspeed in the same time as is my statistical mistake :confused:

all of this is without installed or activated V-ray to new RH6. I have even reduced antialiasing and turned off GPU tessellation and turned off vertical sync - no effect.

Joe,

This is a mystery :slight_smile: Do you think it would be possible for you to record your screen when you reproduce the bug? There might be something going on that I’m not taking into account. You can download OBS which is free: https://obsproject.com/.

If you don’t want to record your screen, can you take a screen shot?

If you don’t want to post video/screen shot of the model here you can send it to david.eranen@mcneel.com.

-David

I can do that, do you want me to record whole reinstal, or just the command? Eventually, I can show you directly through teamviewer.

You can start recording just before you open Rhino until you have reproduced the bug.

-David

Here you go, I have send you on your email the recording file. I have tested the file in RH6, RH 7, there is shown GPU usage and actual version of both Rhino and GPU driver. As a bonus there is playing Pay the man on the background (if you do not like Offspring, please turn of the sound :slight_smile: )

As can be seen, GPU usage is only about 15%. When I switch to RH 7, GPU usage rises to about 50%, still not optimal, but much better.

Hi @jan.jaron,

I looked at your video on Friday and I can’t find anything out of the ordinary. It looks to me like Rhino is bottlenecked by the CPU, but I’m not 100% sure. I will do some profiling to see if anything stands out as being the main cause for this.

-David

Hello David, I do not see how CPU can be the problem, when I show on the video GPU usage, CPU usage is visible as well, there is only around 25% CPU usage during the test. But at the moment, I am openned to anything. If you need me to run some another test, just reach out here or by mail.

@jan.jaron,

You said Rhino 6 used to work fine when you bought it. What about other large files? Are they still faster than the 29MB file you sent to me? Is the 29MB file the only file that is slow for you?

I’m wondering if this is something that started happening in the last few weeks/months. Would you be willing to try some older versions of Rhino 6 to see if they have the problem or not?

-David

No, large files are even worse. It is not about this specific file, I use it all the time for testing purposes to have comparable data. I am not sure when it started to be slow, but we are talking about months. Firstly, I have just tried everything, checked for GPU driver and RH updates daily, and nothing helped. In the last month, I have reached point of realisation, that update won’t solve my problem and then I wrote here.

I can try older version of Rhino, I am not sure, If that helps, my guess is, to reproduce state before problem happened, I’d need to instal some old GPU driver aswell.

Please try this build from 12 months ago: http://files.mcneel.com/dujour/exe/20190823/rhino_en-us_6.17.19235.15041.exe

Any better, or still the same?

-David

Also, next time you install NVIDIA drivers, please make sure you check the following Clean install checkbox:

image

6.17 build did not help - 42,39 sec

I perform clean Instal every time.

Clear idea is, GPU must be malfunctional. But how can that be, when RH 7 is working more or less smoothly (even in RH 7 is running slower, than I’d expect, but it is MUCH better, than RH6), and RH 5 is the same, it is working better than RH6.