Rhino 6 Modeling Commands Keeps Freezing in Windows 10

Hello,

I installed Rhino 6 three days ago. It was working beautifully for two days until today it exhibits following behavior:

  1. Rhino 6 takes much longer than usual to start up.

  2. In files or in new blank models, panning, selecting, dragging, etc (anything that has to do with modeling) takes about 30 seconds to process.

  3. Commands like SystemInfo or things like Tools>Options can be accessed like normal.

What could be wrong? I was modeling like normal and it suddenly slowed down. Here’s the system info:

Rhino 6 SR8 2018-8-28 (Rhino 6, 6.8.18240.20051, Git hash:master @ d037927543424e8b3ce54e46b435866178a6349c)
Licence type: Educational, build 2018-08-28
License details: Cloud Zoo. In use by: yc525 ()

Windows 10.0 SR0.0 or greater (Physical RAM: 7.6Gb)
Machine name: DESKTOP-HPD65F4

Intel® HD Graphics 4000 (OpenGL ver:4.0.0 - Build 10.18.10.4276)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.0
Shading Language: 4.00 - Build 10.18.10.4276
Driver Date: 8-17-2015
Driver Version: 10.18.10.4276
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2112 MB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.8.18240.20051
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Might I add that I am able to open all files and operate as normal in Rhino 6 safe mode.

I would start with the video card driver. It is a bit old. The latest driver is from January of 2018.

Your display adapter driver is quite old.
It also is quite old.
A new driver is the first thing you should get sorted.

I tried installing the updates for intel. but it keeps telling me “The driver being installed is not validated for this computer. Please obtain the appropriate driver from the computer manufacturer. Setup will exit.”

I think it’s this one (https://downloadcenter.intel.com/download/27417/Intel-Graphics-Driver-for-Windows-15-33-?product=81499) but maybe I am looking at the wrong product?

I think that’s the right driver.
It could be the laptop maker has tweaked the drivers to save power.
Have you checked for an update from them?

This laptop has to be 5-6 years old now and well past it’s expected useful life span.
Any plans for a new computer?

Yes… I checked with Samsung and the newest VGA driver available for this device is from 2012… even that I cannot install because the computer doesn’t meet the system requirements… I didn’t have a new laptop planned in my budget yet… not sure what to do :’(

Well, it boils down to you having a computer that does not meet Rhino V6’s System Requirements.

You could try Rhino 5 on the machine and see how that runs. That is a potential solution.