Rhino 6 material


#66

it were the lights, now they’re gone the ghosting is gone too.


(Jeff Lasor) #67

@All Well, I just sent the P5000 off to Dale Fugier…so unfortunately I don’t have it here… I do have a 4000 and a 6000, which I run daily… I will load the file up on the 6000 and see what I can find.

Please stop disabling hardware and updating drivers… IMO this is 100% a Rhino issue… If you’ve disabled anything, please go back and re-enable it …get Rhino back to its Defaults please, so that we’re working with the same settings and results.

I’ll post back here shortly…

-Jeff


#68

you’re fully right… I thank all guys involved for the assistance thus far, but it’s really just patching things up. the main problem seems to be somewhere in Rhino 6 itself.

I purchased a top of the line Quadro P5000 with the hope of having a modeling environment with no disturbances or glitches…and be able to put on whatever lighting or material mapping I’d like… seems like that’s not yet the case. I hope you guys can find a solution soon! Good luck!


(Jeff Lasor) #69

Hi @Arman_Fissette Your P5000 should work extremely well with Rhino V6… I have (had) one up until yesterday…and all of my testing showed pretty impressive performance and results…obviously we missed some things…but we’ll figure it out…

Thanks for your patience and feedback on this…and please do not hesitate to report any/all problems you have in the future.

-Jeff


(Jeff Lasor) #70

@andy @johnc Well immediately upon loading his file I see issues in the ME… Several materials show as “selected”…and yet I have nothing selected… I have no idea what that means atm, but it sure means something is bugged in the ME.


(Jeff Lasor) #71

@andy @johnc Also note the “yellow” materials… they’re not really supposed to be yellow. When I right-click and rotate the material icon, the ME uses the display pipeline to render the thumbnail…at that point it looks correct…but when I release the mouse, the renderer is then used to create the thumbnail, and I get incorrect result… This happens on quite a few of the materials…and the results are always the same…“yellow”, regardless of what the material really should be.

Just FYI and current observations so far…

-J


#72

regarding the ghosting problem…I also get the ghosting when both the sunlight and skylight is activated. just skylight or just sunlight doesn’t have the issue. Seems like as soon as there as multiple light sources (like with the three lights I placed myself), the issue arises.


(Jeff Lasor) #73

@Arman_Fissette

So far I’m not seeing anything like that… If you run TestMaxSpeed… does it happen? What about TurnTable?

I’m basically trying to eliminate the mouse from the equation…

-J


#74

yes it happens. You do have to have a surface selected though… otherwise it’s not going to show


(Jeff Lasor) #75

I’ve tried all combinations… Do you have any other kind of pointing device attached? Like a SpaceMouse or a 3D-Puck?

Here’s what I’d like… Once you have a state that shows the problem… Save it out to a new file… Close Rhino… Start Rhino…Load the new file… And without doing anything else but rotate the view… Does it happen? If not, select an single surface and rotate the view…does it happen? If so, please send me that file…and if your display mode is not at its defaults, please export it and send that to me as well.

Thanks,
-Jeff


(John Croudy) #76

@Arman_Fissette I can only help with the flickering material problem that I saw in the video, and the yellow material problem. If I can get the 3dm file(s) that causes those issues, I can start looking for the problems.@BrianJ Could you log a bug for me and attach any 3dm files you have that show these Material Editor problems? Thanks.


#77

no other pointing device attached.

I saved the file, started it up as you said: spin the modelwithout nothing selected, there’s no ghosting. When I select a surface, it’s there. Same as before.

I’ll send the file . Which email to use?

Here’s the display mode:

Rendered.ini (11.3 KB)


(Jeff Lasor) #78

jeff@mcneel.com

Thanks.


(Jeff Lasor) #79

@Arman_Fissette

Ok got the file…but still no flickering or ghosting here… However, I do see some strange behavior with the shadows when I select and unselect a surface…

Do you see the problem if:

  1. You turn off shadows?
  2. Restore Rendered mode to its defaults?

…please try those as separate operations and not together…

Thanks,
-Jeff


(Jeff Lasor) #80

@Arman_Fissette

Also, what happens if you run TestShowShadowMap and then try to reproduce the problem? All you should see are the shadows… note: Shadows must be on obviously.

With the shadow map display ON, can you get the ghosting and flickering?

…run TestShowShadowMap again to turn it off… it’s a toggle.

-Jeff


(Brian James) #81

Done.


#82

when I turn off shadows, there’s no ghosting. Same thing as when I turn off groundplane (which was set to show shadows only).

How to restore the rendered mode to default?


#83

with TestShowShadowMap there’s no ghosting issue. No flicker either. (I don’t have flicker anyway at the moment. All my materials were deleted…


(John Croudy) #84

Thanks Brian. The flickering is exactly what I suspected – a continually firing timer in the RDK. I’m fairly confident that I can fix this today. This issue is isolated to the Material Editor and will not have anything to do with the other (ghosting) problems mentioned in this thread.


(Jeff Lasor) #85

@Arman_Fissette

Ok thanks…still digging into this one here… unfortunately a family emergency has come up and I’m currently out of the office now… I will get back to once I have more information and possible things for you to try.

Thanks,
-Jeff