Rhino 6 material

unhandled

(Brian James) #46

You have an environment map set to 22% on the applied material. Disable this channel in the material.

Regarding the lagging ghosted image you get when rotating in Rendered mode, I am not able to reproduce that here. Let’s try disabling your GPU as a test. Go to Options>Advanced and type OpenGL in the search filter. Then disable Use Hardware Driver… Any change?

I also do not see a load on the CPU here in testing your model. At the moment there seems to be something system specific that is causing this issue but I’m not sure what it might be. What exactly are you doing when you notice this in the Task Manager?


#47

I want to isolate all the materials I have currently in use in the file, then purge. Just to make sure all the materials in the file don’t use this environment map. Where can I find the tool to purge to unused materials? I’ve sen it somewhere before, but I can’t find it now…


(Nathan 'jesterKing' Letwory) #48

_Purge


#49

ok, would be handy though to just right-click on materials and have it there, like in Vray, or Maxwell. Just my 2 cents…but thanks!


(Nathan 'jesterKing' Letwory) #50

You can right-click in the material editor and choose to show unused materials.


(Brian James) #51

I just stumbled upon your Properties panel and Materials panel flickering @Arman_Fissette while continuing to test the file. I believe the issue is that the objects are confused about which material they should have applied. Delete all the materials please and save a new version of the file to test. This solves the issue of the flicker here. I also deleted the four directional lights and switched your model units to Meters accepting the scale… this may not be a factor but it seemed more logical.

I’ll keep trying to figure out why the materials are confused, can you tell me where the model originally had these materials applied and what the render engine was?


#52

there’s something I can’t get my head around in Rhino6 though. I can’t just seem to see the materials listed, unless I have a surface selected. Only then I get access to materials. We’re talking about this as being the material editor:?

image

Or is there some other window, where I can interact in a different manner?

When I right click in that window. there’s no option to show unused materials, not when I right click on the pingpong ball preview, nor when I click somewhere below ii\t in the window.


(Nathan 'jesterKing' Letwory) #53

The material editor is the same icon, one row up.


#54

The model always was in Rhino 6, render engine always Rhino


(Brian James) #55

Yes, from the Panels drop down menu select Materials, this opens the Materials panel. Properties>Materials is per selection, but again, I’d get rid of these materials… somethings wrong in how they are assigned.


#56

Jesus, that doesn’t make sense IMO… two similar icosn right next to ane another, giving different window to interact…


(Nathan 'jesterKing' Letwory) #57

Agreed. I think the one you used should be phased out.


(Brian James) #58

okay thanks, did you make and apply the materials or import them somehow? If you did make them, did you use the Properties panel when multiple objects were selected?


#59

I concocted them myself. No idea what I did when I made them, it’s been weeks ago…


(Brian James) #60

I disagree, editing a material as an object property and editing materials when nothing is selected via the materials panel both serve a purpose.

Let’s not get distracted with UI review though while we try to solve Arman’s issues… this thread is already pretty long. :slight_smile:


#61

Ok, I deleted all materials, saved the file. restarted Rhino and opened file again.

Still I get the same ghosting…


(Brian James) #62

Did you disable your GPU as I explained? The delete of the materials is what solved the Panel flickering not what I assume will help the ghosting.


#63

Now I did. However, no the model is just static. Doesn’t move, sometimes I get a short flicker, where the model I turned, but it immediately goes back to static view…


#64
  • this is what it looks like:

https://photos.google.com/share/AF1QipMN2x11evb02FvmySblvslgrI2ghphoMArkH73dhm4XIFwrLhUIHBToOeqhi3lFkQ/photo/AF1QipP9ShTDXaazZPeGvX968MxeYAf49KoDFOknxn-T?key=Sk4xb1MxNVNVTnRYWjBvMzJFcmxBYU1FZTkwSUd3


(Brian James) #65

Okay thanks for checking that. My hunch is that the Quadro P5000 GPU or it’s driver is the culprit but @jeff one of our display developers will need to let me know if I’m right on that.

Do other display modes work? Does Rendered mode work without Shadows enabled in the Display panel? Try deleting the directional lights too please.