Rhino 6: IGES tolerance not saved

Hi @tim ,

this value is always resetted to 1 here in Rhino 6.5.18155.13161, after I click OK.


Please can you take a look.



Hi Michael, I think this is fixed - hold on a second…

Yeah, it looks like it’s fixed but I have not found the bug report yet…



Hi Michael,

I looked into this today and I cannot repeat it either using the current public build. (6.6.18177.16151, 6/26/2018)


Hi @tim ,

sorry, I use the same current version and here it is still not fixed. I change the “IGES Tolerance” to 0.001 and it resets always to 1 for the next save. Also I switched from the german to the english interface with no difference.

Tell me, if you need more information or a video.



P.S.: Also when I cancel the “IGES Export Detailed Options” window, I get still this annoying warning:


Did you do that for Rhino, or for Windows? This sounds like a locale problem to me. A convoluted example to redo is (on my machine) to type 0,01, switch to simple controls, and back to detailed controls. @tim, this might help in figuring out what the problem is.


Hi @nathanletwory,

you are right. Typing 0,001 works, and changes the value to 0.001. That’s better, but not good.



Ok, that clearly is a locale problem. This should be enough info for @tim to get this fixed.

@Michael_Meyer, did you update to the latest 6 SR 6 and test with that, too? (before I create any new YT items).

Hi Nathan,

my version is 6.6.18177.16151, 26.06.2018.



Ok, thanks. Reported as RH-47046

I tested a fix to this, it should be available in 6.8

1 Like