Rhino 6 | Grasshopper - Arctic, Render or Raytraced mode display request

We may be able to look at the display mode attributes to make decisions on drawing curves and points.

Maybe it would be nice in a future release or upgrade inside Rhino display general settings a simple checkbox with classic grasshopper settings :" don´t draw any preview geometry, draw wire frame preview geometry, draw shaded preview geometry"; for a intuitive management.

Filipe.

1 Like

This is something we discussed, either a separate checkbox in display properties for Grasshopper previews or some more generic mechanism. It is still something we can do, we just wanted to start with the simplest no-options approach and see what annoys people the most.

2 Likes

:rage::stuck_out_tongue_winking_eye:

I think it would be great to have native preview components (that work in rendered) like the ones in the human plugin where you can specify lineweights and and also preview bitmap textures…

@DavidRutten
This has been a big issue for us. We desperately want to be able to see points and lines in rendered viewports as we had a lot of scripts for visualizations that were built to work in that way.

What is odd is what triggers the grasshopper display turning off is not shadows being shown or edges being off, but if “Color and Material Usage” in the display settings is set to “Use Rendering Material”.

If I create a “Shaded” view style but then want to see my material maps it turns off the grasshopper preview, even if there are no shadows and rhino is showing all of the curves and edges on the document geometry. If change the setting to “Use Layer Color” then I can use all of the Rendered views and Arctic views that I want. Curves will even show up in raytraced mode! (raytraced mode isn’t a big concern though)

The example below shows a box turning on and off, which I realize could be solved with the preview component, but this applies to points and lines as well which the preview component can’t solve.


I modified the behaviour about a week ago in the 6.x code branch (which you should be able to get probably already this week, otherwise next week if you’re on the Service Release candidate update schedule). The preview is back to normal again in all viewport types, the only difference now is that the Custom Preview component either draws directly or pushes meshes+materials depending on viewport mode material usage.

This means you still won’t be able to see coloured curves and points that come from a Custom Preview component in render-like viewports.

Here’s Arctic in the current build-of-the-day we use internally:

3 Likes

Amazing! This is great to see!

Very good it seems to work,
Shaded
image
Rendered
image
Pen
image
Artic (with default settings)
image

But still no shininess in rendered mode with custom Material


Will this change in future releases? I would be in favor for that. This is especially handy with the custom line weights component from human.

Which release supports the latest changes? I have Version 6 SR5 (6.5.18143.7081, 05/23/2018)
but still experiencing the old behavior.

Human components should behave like regular components, it will work. Custom Preview probably won’t be updated again for GH1.

Thank you David! That would be great and already practical if external preview components like custom preview linewights and custom preview materials (with bitmap textures) from human would work as well in Arctic, Render or Raytraced as it was in Rhino 5.

As you really want to be able to use these components especially in junction with rendered display modes.
However in my actual build (Rhino Version 6 SR5 (6.5.18143.7081, 05/23/2018)) the don’t work in this modes so I’m a little confused if this change already took place or not…

Arctic and Raytraced didn’t exist in V5…

Busted! But it worked in rendered…

It should, assuming they just use the regular preview mechanism.

What is

?

So the changes you described in that post are not present yet in the latest public built ( SR5 (6.5.18143.7081, 05/23/2018))? Sorry I’m confused about that now.

Sorry, bit of internal jargon there. Any work on Rhino6 happens in code labelled 6.x. Then every month or so we make a copy of the current 6.x and call it 6.1, 6.2, 6.3, etc. We no longer make changes to this copy, except if people find bugs which are then fixed.

I made my changes in 6.x, meaning they’ll get included whenever the next Rhino6 service release is copied. It may be 6.5, maybe 6.6.

If you want to know whether a specific issue has been fixed and is available in your current Rhino installation, you can use the _GetIssueState command. Of course you’ll need to know the issue id, which in this case is RH-45046. The feedback from that command is pretty geeky too, but if included=true, that means the version you currently have contains the new code.

You can also view the issue online, by using the same id with the url: https://mcneel.myjetbrains.com/youtrack/issue/RH-45046

Thanks David, this is very helpful.

Thanks for the info! The changes are carried over to the current public release now. Everything is working great! Awesome!

@DavidRutten It seems there is some buggy behaviour if a slightly modified version of the Arctic Display Mode is used.

  1. Create a copy of Arctic - I named mine “Arctic HeavyLines GH”
  2. Surface Edge Settings->Set Edge thickness (pixels) to 3 pixels
  3. Objects->Surfaces->Change Edge color usage to “Use single color”

Now try using custom preview and switching between Arctic, Arctic HeavyLines GH, and Shaded. Geometry rendered by GH gets “stuck” in the render pipeline, and even if geometry preview is disabled, the geometry remains previewed.

Preview in Shaded mode, with GH preview disabled - box is hidden as it should be:

Preview in Arctic or Arctic HeavyLines GH, with GH preview disabled - the box still shows up:

Would be great to get this working, as it’s really useful to use Arctic with more emphasis on the edge curves.