Rhino 6 - Extend Surface - Change Surface Feedback Colour

Hi, I like to work with a black viewport background, however, the feedback items for extend surface in Rhino 6 sometimes show up black rather than the surface colour (see image) which is impossible to see. How can I change this? It doesn’t seem to be represented in the appearance / Colors settings.

Hello - the extension should be in the current layer color - is that what you see? I’d agree that object color might be a better choice, I’ll check with the developer.


Hi Pascal, Thanks for the quick response.

If I explode to surfaces and then run the shrink to edge command it does indeed display the extension in the layer colour. However as far as I can tell it displays in black if the surface has been trimmed in some way. That’s actually pretty useful behaviour as trimmed surfaces don’t always extend as you would like (which is understandable). It could actually be quite useful feedback (just not in black in my case).

Hi Paul - yeah, that is wrong - thanks for pointing that out. It should follow object color I’d say, or if it is handy to be different for trimmed surfaces, then that one could follow Feedback Color in Options > Appearance > Colors.



No worries Pascal. Following the feedback colour would be perfect.