Rhino 6 Exporting Mesh

unhandled

#1

I recently upgraded to Rhino 6, and i use grasshopper to save out/export an OBJ mesh once i’ve aligned it and worked with it in Rhino.

In Rhino 5, i was using “Object Save” option in grasshopper (which i think is a lunchbox plugin). It worked fine before, but when i try to run it now - my computer hangs and it never finishes.

I tried another option, Export Objects, which is Elefront plugin. Computer still hangs and never finishes.

Finally, i tried the _Export option in Rhino itself. It also hangs and never finishes. Any help? Ideally I’d like my mesh to be saved in roughly the same format as it exists in Rhino.

Thanks


(Pascal Golay) #2

Hello - see if un-checking the option to write nGons to the obj file helps.

-Pascal


#3

Hi Pascal,

Another caveat, I’m also using a new computer than the one i used with Rhino 5 (but this computer is much more powerful)

When i’m exporting, the rhino program goes unresponsive, but i can see that OBJ file is being updated. This export usually took less than 15 seconds - but now is going on for minutes.

I unchecked the ngon box and it had a small effect. It seems to finish the meshing now - but it’s still taking MUCH longer than it ever did before. I timed it and it’s taking about 3 minutes. The output file is about 30 mb.


#4

I still have a 10 year old computer with rhino 5 on it so i tried to look at the export settings on that and copy them.

No change, the new computer with rhino 6 takes minutes to do what the old computer with rhino 5 can do in 10 seconds. Are there any other settings i can look for/change?

New computer is 8th gen i7, 1070, 32 gb ram

EDIT: I uninstalled Rhino 6 - and cleared out the grasshopper and mcneel folders in %appdata% thinking there might be a conflict. Reinstalled Rhino 6 and I tried running the export mesh with vanilla options and it was still very slow. However, I am exporting to a network location. I tried exporting out to the C drive and everything worked almost instantly.

I haven’t noticed any other network slow downs. I’ve gone from Rhino 5 on windows 7 to Rhino 6 on windows 10, so there a few variables at play. The Rhino 5 10 year old computer is writing to same network with no problems.


#5

@pascal

I downloaded the trial version of Rhino 5 onto my computer. There are no problems saving to the server, and it exports in a few seconds. If i switch back to Rhino 6, the export problems to the server remain.


(Pascal Golay) #6

Hello - thanks for the update - can you tell me if formats other than obj are slow as well?

-Pascal


#7

Exporting to a network location:

Exporting the object as a Rhino 6 3DM file occurs instantaneously
Exporting as a ply occurs instantaneously
Exporting as a STL (ascii) takes about 12 seconds
Exporting as STL (binary) occurs instantaneously
Exporting as points (txt) occurs instantaneously
Exporting as dae occurs instantaneously
Exporting as amf takes about 20 seconds
Exporting as obj takes 90 seconds to 3 minutes


(Pascal Golay) #8

Thanks - and just making extra sure - you’re definitely not creating ngons in the obj export.,right? Also, are you running the latest (as of yesterday) sr of V6? That would be 6.2 - see Help > About Rhinoceros.

-Pascal


#9

Hi Pascal - ngons is definitely not checked.
Obj exports very quickly to local drive, problems are with network

I have 6.1.18037.13441 , will update now. In Rhino Options -> Updates and Statistics, it says the mcneel update service is unavailable (last checked: unknown).


(Pascal Golay) #10

Hm… weird - see

https://www.rhino3d.com/download/rhino-for-windows/6/latest

for the current installer .

-Pascal


#11

Updated to 6.2.18065.11031.

Don’t notice any difference from 6.1.18037.13441

EDIT: Automatically updated to 6.3.18064.23201, 3/5/2018. mcneel update service looks like it’s working. Checked to see if this changed anything but exporting behaves the same. Strange that the date on 6.3 is 3/5


(Pascal Golay) #14

Hello - I’m checking with some bigger brains… thanks for the info.

-Pascal


(Benbrady) #16

Hi there,

I am having the exact same issue. I used to have no problem exporting OBJ from Rhino but since I have updated to Version 6 it freezes and crashes. My files are NGon free but significantly larger than mcmucher’s. Exporting to the network crashes and exporting locally works better but it can take a really really long time. Has anyone had any more clarity on this subject?

Thanks!


(Pascal Golay) #17

Hello - thanks for the information- we are still trying to track this down - it would be helpful, if you are willing, if you could download the current V7 WIP build and try the ply format export. The test is somewhat ‘negative’ in that it does not offer a fix yet, but we’d like to know if on systems where the V6 obj export is slow for whatever reason, the latest V7/WIP ply export also turns out to be slow… If it is, then that will help us pin down the problem.

https://www.rhino3d.com/download/rhino/wip

-Pascal


(Benbrady) #18

Thanks Pascal - I downloaded the current V7 WIP build and successfully exported a ply format file. (3dm size approx 150mb, ply over 1GB) and it took a couple of minutes which seems fast for the size and didn’t crash the machine. The OBJ file crashed the program though.


(Pascal Golay) #19

OK - thanks very much for testing and getting back to me. I’ll let the developer know… That is not what I was hoping - and since the change is recent, it actually may be that the current WIP does not have the very latest ply plug-in. I may ask you to try this again next week, just to make sure. We’d love to be able to reproduce the OBJ lag here but is just works so far for everyone here.

-Pascal


(Benbrady) #21

Sure thing- thanks for checking on it. I’ve never had any issues with Obj exporting from Rhino until I got Rhino 6. It’s part of my daily work-flow and I thought it was maybe my machine communicating to the network but I don’t think that is what is going on as it is often crashing when exporting locally too.