Rhino 6 export in FBX - I cannot not get any materials exported :-(

I am trying since a few days now to somehow get materials exported with my 3D objects I create with Rhino 6 for Mac.

It seems there is just no way to make this work.

Here is the rough workflow:

  • use 3D assets from 3rd party software (3D, Materials, Textures)

  • export from 3rd party software for use in Rhino (export plugins Rhino understands at least partially are: FBX, OBJ (lots of issues), 3DS (lots of issues)

  • import of data into Rhino 6 (FBX so far works ok, 3D objects, materials and textures are mostly imported)

  • work in Rhino (creation of new 3D objects, assign materials, textures, restructuring files, …)

Now we come to the terrible part:

  • export of data from Rhino:
  • FBX - 3D objects are exported, even textures can be saved but third party software simply does not read any material or texture information - when trying to import these files with the latest version of Blender an error message pops up that the file format is outdated
  • OBJ - lots and lots of issues with flipped normals although all was well within Rhino
  • 3DS - limitation of object / group / file naming + incompatibility of texture formats -> no textures + garbled and truncated object / group / file naming

Now for what I need to accomplish there is a perfect solution everyone tells me - buy Autodesk 3DS Max and be done - I know it would work but I simply do not want to buy 3DS Max for 2K a year as a glorified file export/import tool (as I simply would want to continue to work in Rhino anyway).

What hurts is that the needed I/O is right there in front of my nose on the screen - Rhino has all the I/O I need - I just cannot make it work !@#$%

See if this helps:

I saw that post among some others relating to “FBX” and people having problems exporting materials or more specifically textures attached to objects (it seems material settings do or do not get exported but textures are completely missing / not attached).

I just now spent another hour or so doing some very basic experiments.
Could you perhaps try to answer a few of these to get me on the right track to dig deeper for a solution?

1st I manage now to reliably crash Rhino 6 every single time when loading into the material selection menu - it crashes … every …. single …. time ;-(


  • are there any restrictions to certain texture files not being compatible with Rhino (they render ok when the model is loaded and rendered but the moment you open the material menu and try to browse the materials, Rhino 6 crashes … every …. single …. time reliably)
    The model I am trying to load has DDS texture files


  • are there perhaps any limits to the number of different materials Rhino 6 can handle when loading the material selection ?
    I am on a REALLY beefy computer (fully loaded BTO 2018 MacBook Pro) and Rhino absolutely flies without any hiccups for my work related stuff (surface and solid modeling CAD work, no meshes, no materials, no rendering but quite complex 3D models).
    When loading the material menu with the model I am trying to tidy up Rhino just freezes as if I am trying to load a planet - compared to my CAD work stuff this model is really laughable in complexity and yet it absolutely brings Rhino to its knees :frowning:

I have also done more experiments both trying to export the model directly after import without any changes to the file and it just does NOT export any textures at all (just the single FBX file, no matter what export options I choose).

I have also created a new 3DM file with just a single cube mesh created and tried to apply a texture - the moment I open the image file dialog and click on any of the DDS files that came with the problematic models texture folder … Rhino 6 crashes reliably.

I am perplexed and the only idea here on my side is that there is some sort of restriction as to the texture file format not being well digested by Rhino 6.

I did check the same model also in Photoshop CS6 (my old non updated perpetual, not the current cloud based release) and the textures load fine on the model.
The model also loads without issues in the two 3rd party apps I am trying to feed the data into (gaming related model editors: 3DSimED and KSEditor) - both have no problem with the initial FBX model and textures - just Rhino 6 doesn’t like it :frowning:

I really, really would love to make this work as I am familiar with working in Rhino and I really want to avoid Autodesk 3DSMax for these fun side projects.

Is that the material section under the properties panel?

Are you able to use the materials panel instead?

If you could create a simple 3dm file with which you can get Rhino to crash and attach it here.that would be useful.

There shouldn’t be restrictions. If it shows up in the viewport it is supported clearly.

I will try to do that later once done with work.

I have opened the floating material panel a couple times and worked with that instead (and used assign material to object function instead of selecting the materials in the panel).
I do not recall Rhino having crashed that way but that could be circumstantial.

What is very bothersome with this whole situation is two major issues:

  1. Rhino crashes when browsing materials in the material panel (I doubt it has something to do with one material from an FBX import that Rhino does not understand / think is corrupt)
  2. browsing the materials in the material panel is EXCRUCIATING SLOW, sluggish, laggy (basically even without the crashes it is impossible to use efficiently in a fast paced 3D design workflow)

This really shouldn’t be an issue of hardware limitations in my case - perhaps something to do with the original FBX file / format / materials ?

If you could provide me with a means of sharing the original file in private I’d be happy to do it that way (~50-100MB) and you surely could diagnose the issue easier :wink:

You can ZIP the file and upload it privately here:

Add you email address and include this URL in the Comments: