Rhino 6: direct object snapping is not working, where to look?

unhandled

#1

Hi…,

here an example for direct object snapping:
Direct_Snapping

I have done a Rhino 6 training. At one PC direct object snapping was not working. Where to look?

Thanks

Michael
www.flexiCAD.com


#2

Yes, I’ve seen that too. I thought I had done somthing wrong. It’s not like in R5 anymore. Broken.

// Rolf


#3

Hey Michael,

No snaps at all showed up on any kind of object even though they were enabled? Wonder if that might be due to a graphics card/driver issue…

–Mitch


#4

It was yesterday or the day before so I don’t remember which kinds, but it wasn’t on all kinds. Line ends worked well (IIRC) but a Box Brep wouldn’t resize (or the other way around, it wouldn’t move, but would resize, I’ve forgotten now which way).

// Rolf


#5

Those would be Gumball handles, not osnaps, or?


#6

I held down the mouse on OSnap End. Well, that’s what I thought I did. I should try again so as to not give any false leads. I’ll try it in a bit, have to finish some other task first.

// Rolf


(Pascal Golay) #7

Hi MIchael - one thing to check it Options > Modeling aids > Snap radius. I think the default is 15 pixels.

image

-Pascal


#8

It seems I had done something wrong. I just realise that I have to click-release once on a control point before I can then “snap-drag” it.

I tried snap-grab-drag it on first click, which only makes the entire object moving. So I obviously were wrong and it works as designed.

// Rolf


#9

image

You have this checked in Options>Mouse… If you uncheck it you can drag control points (or anything else) immediately without first click-selecting it.


#10

Hi Pascal,

even when I set the radius to 0 it works here. Sorry, I have now no access anymore to the customer computer.

Thanks

Michael