Rhino 6 / Dimension Problems

Testing Rhino 6 for drafting i recognized, that the orientation of the vertical dimension is not working correctly.
Should be readable from right side… seems to orient to left or right side…


This is a new problem that i faced now. Sometimes i have to move the number of one linear dimension to make all the numbers in a chain readable. I did that and after that wanted to move all the dimensions as well as the object itself. The number i first had moved did not move with all the elements!

One thing more about dimensions that is quite annoying:

Linear Dimension always automatically connects to the last chain. Even if a couple of other commands have been done since the last dimension. So you might already work on a complete different object and the dimension connects to the last chain, which is somewhere else in the file…

Yes I reported this as a bug several weeks back. I agree with Thomasn it is very annoying behavior when dimensioning a page of drawings.
Curious here but how does one know if a bug has been acknowledged and logged? There was no reply to my post or this one and often you guys jump right in to this.

@thomasn -
Can you post a file with an example of the dimension text on the wrong side of the dimensions?

I can fix the dimension text that has been moved not moving with dimension history update.

You didn’t mention if you see how the chain mode works as a toggle. Are you asking that it reverts to off and doesn’t remember where you last made a dimension?

Hi! Thanks for answering.

  1. i exported a part of my file, unfortunately still 88mb (!) although nothing is in there. can i send it to you via wetransfer, so you probably can tell me why it is so big…

  2. thanks for fixing the bug

  3. i think dimensions should not continue the last chain by default when other commands have been done. imagine: you dimension a part. then you continue modelling. after 5 min you want to dimension a different part. right now the dimension is continuing the old chain - that is positioned somewhere else in your model…


@thomasn -
Is this just 1 file that you have with dimensions oriented wrong? I mean, do you know how to make a new small file that has the problem?

As far as getting the file size down, some things to try are Purge, SaveSmall, and Export selected objects. If none of that works, I can look at the big file.

About continuing dimensions - the way it works makes sense to me (which doesn’t count for much as far as being right) - and I tried to make it as flexible as possible to toggle continue on and off or attach to other existing dimension chains. It’s always a dilemma when something gets this far along to change a behavior since presumably people not complaining have a different view. Anyway, I can look at the intervening command idea.


i totally understand that it is difficult to react to complains at this point of development.

one thing i would appreciate concerning dimension chains: it would very helpful if the whole chain would be selectable, because most time it is necessary to move the whole chain.

sorry for the filesize problem. i now imported the geometry into a new file. now it’s ok again… but still the dimension faces in the wrong direction (just in top view…)

dimension.3dm (111.0 KB)

@thomasn - That helps a lot. I have a start at being able to fix it.


RH-44366 is fixed in the latest Service Release Candidate
RH-44510 is fixed in the latest Service Release Candidate

What about the orientation problem of vertical dimension. This is still not working?

Hi Thomas - in the latest builds here, your file looks like this in Top:

That is more like what you expect for the dimensions on the left, correct?


Hey Pascal,
obviously not working for me (newest src is installed) - was just working on a file. i marked the wrong directions in red…

Rotation of dimension.3dm (7.9 MB)

Check “Orient text toward reader…” in the DimStyle. See attached.

How do you switch the continues dimensioning on and off?


Found the answer: In the command line.