Rhino 6 crashing very often

Hi Nathan,

I was originally running rhino version ‘6.1.18037.13444’ i had download, installed and now running version ‘6.2.18065.11031’ – however – the crashing is just as bad and frequent, that now i am not using version 6 at all, but using version 5 at uni whenever i can. I would still like to correct this error so i can use the program at home.

system info:

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

GeForce GTX 1050 Ti/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.35)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 3-23-2018
Driver Version: 23.21.13.9135
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

------ To add to this i have done a re-image of my windows 10 in effort to correct any unforeseen errors. I have net 2.0, 3.5 and the required c++ redistributable packages.

yrs arkadius

Rhino is up to 6.3 now. There was a common crash that we fixed in 6.3 which is what you may be experiencing.

Hi Steve and Nathan,

I am pleased to confirm that i have installed rhino6 ver 6.3 [latest] and worked all last night without any problems.

– regarding bugs, i did notice something:

If i continuosly select different curves it will not show on the status bar, if i select the same curve twice it will:

When a curve is selected it does not notify the layer on the status bar, but instead continues to show the current layer. However, if i deselected the same curve and then re-selected it, it will show the second time, but it has to be the same curve.

i will try to see if it happens again tonight, and if so, do i send a report or something?

– the file was a dwg that i had exported from rhinio, but re-opened and saved as 3dm as i decided that particular workflow was not going to work for what i was doing.

I see that from time to time, and not just with curves. I haven’t found a way to reproduce this reliably. If you find a way, let us know!

I have the same problem! Rhino 6 crash very often.
I think that the problem is grasshopper, but I don’t know
InfoPC.txt (2.3 KB)

Hello - does Rhino by itself start normally? Does the crash occur specifically when starting Grasshopper?

-Pascal

Sometimes when I start, sometimes in one or two minutes…
Now I’ve activated security copy and unload some plugins, but the problem continue…
I’ve update to the last version the nvidia driver and the same… :frowning:

What is security copy?

Please run Rhino in safe mode and see if that crashes as well.

This is the error
In safe mode run well.
Security copy is that every x time, rhino autosave a copy of the file
Captura%20de%20pantalla%20(379)
This is the error when I close rhino

Can you disable VisualARQ from the plug-in manager and restart Rhino and check if you still are running into problems?
When Rhino crashes, are you getting a crash report dialog? If so, are you sending in those reports?

Yes! Problem solved!! It was Visualarq!!! :grinning:

At least partly - it shouldn’t crash.
Are you sending in the crash reports?

CC: @fsalla

I’ve meet the problem!! If I run Rhino with nvidia gforce GTX 960M, Rhino crash. If I run Rhino with integrated grafics all go well.
I don’t have crash reports. It could be because I uninstalled rhino 6 completely… I don’t know… I repaired VArq and run Rhino without nvidia driver. Now all run perfect! Thank you for all!

Hi! I really need help I don’t know what’s going on.
I downloaded Rhino 6 for Windows (Evaluation) and now matter what I do it keeps crashing. I use a HP Omen intel Core i7 7th Generation, Nvidia Geforce GTX 1050 and windows 10.
Everything seems to be fine but it still crashes unless I work with it in safe mode. At first I uninstalled it and reinstalled it which seemed to do the trick, although just once. I looked at the error reports and it appears I had “0xc000001d” errors, so I downloaded a program which would fix it. Needless to say it didn’t work.
I’ve read the whole entry and none of the answers given work for me. I just don’t know what’s the matter.
Please, help me.

Hello - can you please run the SystemInfo command in Rhino and paste the results here?

-Pascal

Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)

Licence type: Evaluation, revisión 2018-11-07

License details: Stand-Alone

Expires on: 2019-02-20

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Machine name: LAPTOP-A5BKBPQD

GeForce GTX 1050/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 398.36)

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 8x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation

Render version: 4.6

Shading Language: 4.60 NVIDIA

Driver Date: 6-24-2018

Driver Version: 24.21.13.9836

Maximum Texture size: 32768 x 32768

Z-Buffer depth: 24 bits

Maximum Viewport size: 32768 x 32768

Total Video Memory: 4 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp "Commands" 6.10.18311.20531

C:\Program Files\Rhino 6\Plug-ins\rdk.rhp "Renderer Development Kit"

C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp "Rhino Render"

C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp "RDK_EtoUI" 6.10.18311.20531

C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp "Renderer Development Kit UI"

C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp "Snapshots"

C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp "RhinoCycles" 6.10.18311.20531

C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp "Toolbars" 6.10.18311.20531

C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp "3Dconnexion 3D Mouse"

C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp "Displacement"

Hello - thanks, this seems pretty standard - it may be that installing a video driver update, from the NVidia website may help - there have been some Windows updates since your driver date and now - it seems that in at least some cases, updating the driver is a good thing to do.

-Pascal

What program is that?

I updated it and it still crashes