Rhino 6 crashes when creating meshes

I’ve been working on a file for 20+ hours with no issue. Suddenly, it crashes and I can no longer open the file. I’ve asked my friend to down-save it to Rhino 5 and it worked for a few hours before having the same issue. I’ve tried updating my graphics card driver and uninstalling/reinstalling Rhino 6 with no luck. The file is very large at 105MB but I’ve worked with files much larger on this laptop.

If anyone could help I would appreciate it.

Other files work somehow, I worked on a large 50MB site plan for a few hours instead since this file doesn’t seem to open at all.

image

Here are my system details:

Windows 10.0.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: MSI

Computer platform: LAPTOP - Unplugged [60% battery remaining] ~98 minutes left

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics (Intel) Memory: 1GB, Driver date: 1-22-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 11-9-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.17
> Integrated acclerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-9-2023
Driver Version: 31.0.15.4617
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.35.21222.17001
C:\Users\emily\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino6.Plugin.dll “Enscape.Rhino6.Plugin” 0.0.22353.1023
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.35.21222.17001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Emily -

I’d try updating the drivers for that one as well.

It looks like it’s just busy creating display meshes, and that can take a lot of time. What happens when you start Rhino from a blank template, make sure that all of the viewports are in Wireframe mode, and then Import (i.e. NOT open) that file?

You have left out the lines at the top of that report…
-wim

Probably the one that says “Corporate”

Hi! Thanks for the response.

I’ve updated the driver and still no luck.

When I import the file in wireframe mode it works and I can work in the file. I always work in shaded and ghosted so I’m unsure why it’s not working with this file.

If you have any ideas that would be great! But otherwise, working in wireframe is fine! Thanks again :smiley:

Hi Emily -

When you imported that file, did you then try to set a viewport to the Shaded display mode? If so, what happens? It’s possible you’ll have to let it work for quite some time but you should be able to use the Esc key to stop the meshing process and to return to Wireframe.
You could also do this process in groups of objects: hide 3/4 of all objects and put the viewport in Shaded. Put it back in Wireframe, and, with ShowSelected, unhide another 1/4 of all objects. Put the viewport in Shaded, etc… This might uncover an object that the mesher is having problems with.
If all else fails, you could upload your file here so that we can take a look - Rhino - Upload to Support. Make sure to copy the url of this thread in the comments field.
-wim