Rhino 6 crash when render

I regularly use Rhino 6 on Windows 7 64.
I recently tried installing version 7 and was disappointed to find that it no longer works under Windows 7.
Now when I open a file with Rhino 6 and try to render, the program terminates without any messages.
Also if I switch from wireframe to shaded, ghosted, x-ray, technical or pen, the window remains in a sort of wireframe, while if I select rendered, artistic or artic, it shows a black window.
I tried to ‘repair’ the installation with the last version (rhino_en-us_6.32.20340.21001.exe) but nothing changed.
What I have to do?


try uninstall v7 completely, restart, then uninstall/v6 restart then reinstall v6 and restart.

try render again, any better?

Kyle, thank you for your suggestion.
In fact the problem was related to the video card: on my notebook there is a GeForce and Intel integrated video; for some reason the latter was activated, and since the drivers are very old (I can’t update them), the problem appeared.
I have now reset the GeForce and everything works. :smiley: