Rhino 6 "_-ChangeLayer" not working as I an used to (recently migrated from rhino 4)

Am getting stuck at “ChangeLayer” in Rhino 6. The following use to work in R4 no probs, however I have tried using the command by clicking and am not getting the result I want. Even under the -ChangeLayer command there is “NewLayer” “SelectObject” and “SetCurrent” (I have tried toggling the latter from No to Yes

The layer “TEX” is pre-existing.

-SelColor R 0 127 0 -Properties Object Color Object 0,127,0 PrintColor Object 0,127,0 Enter Enter _-ChangeLayer "TEX" SelNone Purge Enter

Am selecting by Layer by Colour
I select my objects by layer colour, then adjust the visible Object Colour and Object PrintColour,
I then go to "ChangeLayer" and it will not change!

Any help would be greatly appreciated, have tried -ChangeLayer N and -ChangeLayer S but to no avail. Would also like to point out that the layers I have selected by colour exist on two separate layers, and I would like to change all layers to layer TEX

Never mind, I sussed it, I had two layers titled “TEX” (one as a sublayer)

I didn’t realise Rhino 6 could hold more than one layer of the same name.

So my next question is, is there an easy way of cascading any duplicate layer names? Back in Rhino 4 the document wouldn’t allow for any layer names titled the save.

Rhino 5 and Rhino 6 do not allow two top level layers to have the same name, nor can wo sub-layers with a common parent to have the same name. My recollection is Rhino 4 was the same.