Rhino 6 black screen & no orbit or navigation

Dear all,

I have just downloaded rhino 6 evaluation and I see 4 black viewports which I couldn’t navigate or orbit through, even when I maximize a viewport, that is what I receive.

Could any one please help, is it the new windows 10 problem or the VGA hardware
My card is NVIDIA geforce GT540 M



Can you paste the system info here from the Help - System Information menu?

This will make McNeel team address your issue in better way.


Many thanks for your consideration.
Kindly find it below,

Rhino 6 SR25 2020-4-23 (Rhino 6, 6.25.20114.05271, Git hash:master @ f35d7ded15ec317635ced435d8df84327397038d)
License type: Evaluation, build 2020-04-23
License details: Stand-Alone
Expires on: 2020-08-22

Windows 10.0 SR0.0 or greater (Physical RAM: 7.9Gb)
Machine name: MOH_GHANDOUR

Hybrid graphics system.
Primary display: Intel® HD Graphics 3000 (Intel) Memory: 2GB, Driver date: 5-19-2016 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GT 540M (NVidia) Memory: 2GB, Driver date: 3-31-2017 (M-D-Y). OpenGL Ver: 4.5.0 NVIDIA 381.65

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 3-31-2017
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

If nothing is plugged into that old Intel 3000, maybe you can disable it in Device Manager.
Then update the drivers for your Nvidia GeForce card.
That’s a very old computer and the GeForce has less than the minimum recommended amount of VRAM for V6.
I suspect this would have worked pretty well for Rhino V6.

If you’re serious about V6, you need a new computer that meets https://www.rhino3d.com/6/system_requirements.


Many thanks for your feedback, I really appreciate it.