Rhino 6 black screen during startup or opening file while on secondary (4K) monitor. Fine on primary display

@jeff can you take a look at this?

FYI, I noticed I was a couple updates behind on NVidia drivers and updated to 431.70 but the problem still exists.

How are these external monitors attached to the laptop? Are you using any kind of USB hub or DisplayLink?


So the first laptop we had this problem with they were attached directly via HDMI, but on my current laptop it is attached via USB-C to a Thunderbolt 3 hud, then Mini Display Port out from the Thunderbolt 3 hub to the monitor.

It doesn’t seem to be how it is connected but whether it is Primary, but I will confirm today. I will try the latest laptop via HDMI as secondary and see if it still has the issue.

FYI not sure, but it seems like this only began after the 1903 Windows update, although it could have been a Rhino SR also.

Do you want me to try other Rhino SRs?

If you have the time, please do… I’m not sure what would/could have changed to cause any of this, but ruling it out would keep me from looking in the wrong place.

The laptop I currently am testing only has one HDMI out and one Thunderbolt (USB-C)… So as long as you can repeat this with only one or two external monitors then it should be fine… In fact, I’d be curious to hear if you can repeat this with only 1 external monitor…and if not, then 2? Or do I really need 3 external monitors in order to see this?


1 Like

I’m in a meeting till 5 but I’ll try afterwards and let you know. Thanks!

OK, good news, the problem is universal regardless of connection type, or monitor quantity.

I test with 2 monitors, and with 3 monitors, I tested monitors connected via HDMI, USB-C, and Mini DisplayPort. It makes no difference, it simply locks up opening a file showing black viewports, “… creating meshes …” if the Rhino Window is on the Non-Primary monitor.

So IMHO the combination of Windows 10 build 1903, and perhaps Hybrid Graphics is the recipe for the issue.

My previous laptop had the Intel UHD 630 graphics and the NVidia RTX 2070 Max-Q. My current laptop has the Intel UHD 630 and the NVidia RTX 2060 (non max-q edition).

Ok Thanks @jstevenson,

I’ll start looking into this first thing tomorrow… I’ll let you know what I find.


1 Like

@jstevenson So far I haven’t been able to repeat this with my current laptop… Downloading and installing 1903 now to see if that does it.

But I have some questions for you…

  1. By the following…

… Do you mean: You start Rhino, you then move it over to the non-primary monitor, you then load a file that immediately requires meshing, and Rhino locks up? If that’s not what you’re doing, then what exactly are you doing to get “Rhino to open on non-primary monitor” ?

Edit: And if you immediately repeat the steps above, but you leave the Rhino Window on the primary monitor, it doesn’t lock up? I’m starting to wonder if this is related to this:

…which was solved by this:

The “NahimicOSD.DLL” is some 3rd party audio driver that gets attached to all processes, and does a very poor job at enumerating multiple display devices…whoever wrote it assumed that the processes in which they run would never be enumerating display devices as well, and so it doesn’t “play nice” inside Windows’ display device management API… So please check to see if you have anything like the “NahimicOSD.DLL” and/or service running on your system.

  1. Are your monitors configured to “Extend” or “Duplicate” the display?

  2. Is Rhino locked up and non-responsive? Or is it just that the viewports have gone dark? In other words, can you still mouse around and click on or run commands? If Rhino is indeed locked up, then I’d like you to “force a dump” of the Rhino process and send me the resulting DMP file… That should show me exactly where Rhino is spinning… See the attached PDF on how to do that if you’re not already familiar with the procedure. Note: This will also show me if the problem is related to the NahimicOSD.dll I mentioned above…and is how I was able to find that problem in the first place.

Creating a dump file for Rhino.pdf (761.0 KB)

Thanks again for your feedback and patience on this…until I can repeat this, or know where things are locking up, it’s going to be quite difficult to fix…so I really appreciate all the help.


1 Like

Well with 1903 installed, I still am unable to reproduce the problem… So I’d really like to see what the forced dump file I mentioned in my previous post shows.


Sorry just now reading this, I will investigate this when I’m back on Monday. Thanks for the info.

Wow! Fixed! Jeff your the best. I did in fact have the Nahimic Service on my new Laptop (MSI GS65 Stealth), and on the previous laptop (Gigabyte), so this must be something a lot of manufacturers are putting on these days.

If the NahimicService is running when you start Rhino, and you move Rhino to a secondary monitor, it will lock up when opening any file.

Starting the service while Rhino is already running doesn’t cause an issue, it must only hook the window on process startup.

I will be disabling the service, and letting IT know to do the same on the other 70 machines we are ordering.


Forgot to answer your questions:

  1. yes, I’m opening Rhino, dragging it to secondary monitor, the loading a file, it hangs at Creating Meshes… If I repeat that process but leave on Primary Monitor its fine.
  2. Monitors set to Extend
  3. Rhino is unresponsive if you click in the UI it goes “white” and gives the spinning wait cursor. It doesn’t “crash” is just hung.

Thanks @jstevenson, That’s good news and bad news…

Good that you’ve found and fixed the problem… Bad that Dell still ships this “virus” with their laptops. Assuming this is a Dell… Is it? If not, what make and model is this laptop?

I’m wondering if you could do me one more favor? See if there is any kind of installer for the NahimicOSD service…it would be somewhere on Dell’s “Backup CD” or something similar. I really need to see if I can figure out if there’s a way to keep this from happening…especially with Schools about to start up again. I suppose we could just buy a new laptop like yours (and hope it’s on there)…but if it’s something I can just install and reproduce, I’d rather do that.


Never mind… I see you already mentioned the laptop model (MSI GS65 Stealth)… So I retract my negative tone towards Dell laptops :slight_smile:

However, I’m still interested in knowing if there is any kind of installer that I can run here to get the NahimicOSD service running on my laptop… I’ll keep searching the net to see if I can find one…but if you do locate something, please let me know.


It does appear to be something many manufacturers are using now, MSI, Dell, Aorus, Gigabyte. The two laptops I had were from MSI and Gigagbyte that both had the issue.

They have a list of supported PCs on their website, but here is the download in case you want to try it:

The download is here: https://s3.eu-west-2.amazonaws.com/nahimic/Nahimic+2.5.31.exe

Please hold on to the exact specs of your order Jake. If we can’t repeat this, it is probably worth ordering one of the same models that you have.

1 Like

@stevebaer I don’t think we will be able to repeat it without one of these systems… I’ve downloaded all of the installers I can find from the different OEMs (Asus, MSI, Gigabyte, etc…), and none of them will install the Nahimic system unless the very specific hardware exists. I’ve tried to force some of the installs, but I still can’t get the NahimicOSD.dll to load…nor can I get the service to run.

I suppose another approach is the hook LoadLibraryxxx() and create some kind of white-list vs. black-list of DLLs … the NahimicOSD.dll being on the black-list of course…because I’m not even sure there is any I/we can do about this problem even if/when we can repeat it…but I can’t answer that definitively until I have a system that shows the problem.


Figured that would be the case. Jake, can you give us your order information?

1 Like

My current laptop is this:

The other laptop that exhibited the same symptoms is: