Rhino 6 - all fonts artifacting - [Fixed with display driver update]

rhino6

#1

Trying to use v6 but getting this artifacting no matter which font.

(Also, is it normal that when I go to change a font, it’s got a “style” type with dropdowns to dimensions?)

***UPDATE: It prints fine, and also prints to PDF fine. It’s just in the viewport (modeling and layout)


(Pascal Golay) #2

Hi Alan - what video card do you have?
Are drivers up to date?
-Pascal


#3

Hey @pascal

So, this might be getting down to the problem: I think I have some sort of issue with my GPU and Rhino. I’ve had So many problems and they all seem to stem from the video card. I’ve fully updated and then just recent rolled back to my original driver that came with my Acer Predator about 6 months ago or so.

I have a GTX 1080 laptop gpu in my Acer Predator running Windows 10.

Who would you suggest I speak with in order to finally and successfully get my system running the way it should? I did a whole lot of research before getting this system for Rhino (and Vray) both on and off of this Mcneel Discourse site, but I seem to have a bunch of issues other Rhino users don’t have.

As always, your thoughts and help are appreciated!


(Pascal Golay) #4

Hi Alan - Can you run SystemInfo and paste the results here? Just as a test - you’ll want to reset this! - you might want to try Options >Advsanced> type “UseHardwareDriver” and set that to No, see if there is any difference at all, then go back and set it to Yes.

-Pascal


#5

will try in a bit when I’m between things today, thank you.

ALSO: this keeps happening to me - In my FRONT view, I can’t move anything with the gumball, or draw a crv. It’s like I’m stuck to the floor or something. I’ve tried it with Project on and off. Open a new file, it’s fine. Mess around with resetting all viewports, it sometimes comes back. Killing my modeling time. Thoughts on tthat?


(Pascal Golay) #6

HI Alan - post a file with Front showing the problem, I’ll see if I can figure it out.

-Pascal


#7

k will do also in a bit thk u. I did try setting Font viewport Cplane to World Front and fixed it. Is that an ok thing to do?


(Pascal Golay) #8

That is exactly what I anticipated you’d need to do - somehow in your process, Front is getting a CPlane that is not the default and it’s messing you up.

-Pascal


#9

Hi @pascal

Finally had time to do this command line. Here’s what my system gave me:

Microsoft Windows [Version 10.0.15063]
© 2017 Microsoft Corporation. All rights reserved.

C:\Users\alanf>SystemInfo

Host Name: LAPTOP-G130AKNM
OS Name: Microsoft Windows 10 Home
OS Version: 10.0.15063 N/A Build 15063
OS Manufacturer: Microsoft Corporation
OS Configuration: Standalone Workstation
OS Build Type: Multiprocessor Free
Registered Owner: N/A
Registered Organization: N/A
Product ID: 00325-96064-18895-AAOEM
Original Install Date: 8/9/2017, 6:01:00 PM
System Boot Time: 10/11/2017, 9:09:33 PM
System Manufacturer: Acer
System Model: Predator GX-792
System Type: x64-based PC
Processor(s): 1 Processor(s) Installed.
[01]: Intel64 Family 6 Model 158 Stepping 9 GenuineIntel ~2900 Mhz
BIOS Version: Insyde V1.03, 11/16/2016
Windows Directory: C:\WINDOWS
System Directory: C:\WINDOWS\system32
Boot Device: \Device\HarddiskVolume2
System Locale: en-us;English (United States)
Input Locale: en-us;English (United States)
Time Zone: (UTC-08:00) Pacific Time (US & Canada)
Total Physical Memory: 32,708 MB
Available Physical Memory: 25,878 MB
Virtual Memory: Max Size: 37,572 MB
Virtual Memory: Available: 28,198 MB
Virtual Memory: In Use: 9,374 MB
Page File Location(s): C:\pagefile.sys
Domain: WORKGROUP
Logon Server: \LAPTOP-G130AKNM
Hotfix(s): 4 Hotfix(s) Installed.
[01]: KB4022405
[02]: KB4025376
[03]: KB4038806
[04]: KB4041676
Network Card(s): 3 NIC(s) Installed.
[01]: Killer Wireless-n/a/ac 1535 Wireless Network Adapter
Connection Name: Wi-Fi
DHCP Enabled: Yes
DHCP Server: 10.211.0.18
IP address(es)
[01]: 10.211.122.107
[02]: fe80::35d5:8bab:dc59:6644
[02]: Killer E2400 Gigabit Ethernet Controller
Connection Name: Ethernet
Status: Media disconnected
[03]: Bluetooth Device (Personal Area Network)
Connection Name: Bluetooth Network Connection
Status: Media disconnected
Hyper-V Requirements: VM Monitor Mode Extensions: Yes
Virtualization Enabled In Firmware: Yes
Second Level Address Translation: Yes
Data Execution Prevention Available: Yes

C:\Users\alanf>


#10

@pascal,

Sooo…suddenly the text is fine in v6. Without doing anything.

I think I have a problem with my video card, or at least how its interacting with Rhino. Did a lot of research for this computer, so should work fine.

My biggest thing is to get Rhino v5 to work properly so my work stops being effected. Who can I call to take care of this right away? Even if it’s to find out it’s a hardware issue?

Thanks as always


(Steve Baer) #11

This is a bug that occurs in some display drivers. We are still trying to figure out if there is any way we can work around this.

There is an alternate display mode for text that you can use if the artifacts are a big problem. The alternate approach is slower and “fuzzier” at higher zoom levels, so it’s up to you. Run the “TestGlyphy” command to toggle this alternate mode on/off


Text in V6 giving weird results
#12

thanks, @stevebaer. Actually just posted at the same time you were typing, that it suddenly looks ok now. But I have a major problem with v5. Bunch of issues that seem to be related to my video card or something. I asked @pascal who I can call to get myself headed toward a solution. any ideas?

thanks


(Steve Baer) #13

Probably best to post a new topic here or directly email support at mcneel


(Wim Dekeyser) #14

FWIW, Pascal was asking you to run the SystemInfo command in Rhino; not in Windows.


#15

Oh. K will do in both v5 and WIP

Alan


(Nathan 'jesterKing' Letwory) #16

Note that there is no SystemInfo command in Rhino 5


#17

Hi @pascal

Finally got to doing this, having just downloaded and installed the v6 Beta. Running into same Text problem, and now it’s worse. When I select a piece of text, my Properties bar flashes for a good 2-3 seconds, holding up my system. And when I go to move/dup Text, it drags a bunch of surrounding (2D) geometry with it. The geometry goes back to its original position upon mouse release. Hoping you have some key piece of info…

As always, thanks. Here’s the SystemInfo stuff, and I will post that recent file I’ve been working on in v6 Beta.

113_Int Moto’s Bar_111017_v02.3dm (10.9 MB)

Rhino 6 SR0 2017-11-7 (Rhino WIP, 6.0.17311.8431, Git hash:master @ c7eaf5f1ac3236bcd0758e2e49ceec44dfdf2949)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

GeForce GTX 1080/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 384.94)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino WIP\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino WIP\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino WIP\Plug-ins\CyclesForRhino.rhp “Cycles for Rhino”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino WIP\Plug-ins\BlockEdit.rhp “BlockEdit”
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Users\alanf\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.16.484\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino WIP\Plug-ins\RhinoLabsTools.rhp “Rhino Labs Tools”


(Pascal Golay) #19

Hello - I see the odd move problem… still poking…
@Alan_Farkas - at the moment it looks like it is related to draw order. If you select the two BUIILT INS texts and ClearDrawOrder they are no longer semi attached to the curves. I have no idea what is going on there.

-Pascal


#20

Figured out the craziness was only when text had a Background on it. No BG, no issues.


(Pascal Golay) #21

Ah, good catch, I’ll add that to the bug item.

-Pascal