Rhino 5 suddenly wont cap when extruding planar, closed curves


#1

I need some help.
After my rhino crashed yesterday, my rhino wont automatically cap when I extrude planar curves. Before the crash it saved my settings and always capped my extrusions. Now it always says: Solid=No. Then I have to click to change to Yes. Not a big thing, but a little annoying in the end. Can anyone tell me what went wrong in my rhino?


#2

Where are you calling Extrude from? Menu? Toolbar button? Are you sure you are using the correct menu item (from the “Solid” menu) or toolbar button (from the “Solid Creation” toolbar)?

–Mitch


#3

I am using the extrude from Solid Creation - Extrude Planar Curve. Then it extrudes fine, but it wont save the cap setting in the command.


#4

Hi,
are you sure your curve is planar? Try to create another one with project snap on and then use ExtrudeCrv command with Solid=Yes option. Is it working?


#5

Oh i see, this is something strange.


#6

Yes… It is so strange. I have tried it once before in rhino 4. It helped re-installing rhino, but that shouldn’t be the solution. My theory is that its a setting somewhere deep.


#7

Hmm, sounds like it’s not able to save the setting to the registry… Are other sticky settings saved in other commands?

–Mitch


#8

I looks like it is only the solid function. Can I reset the registry settings maybe? After the crash, all my toolbars was also gone, but I restored them to defaults.


(Pascal Golay) #9

Hi Matthias- it sounds like you may have an old toolbar or something- the macro for that, if I am looking at the same button, does include the Solid=Yes option. Please try ToolbarReset and restart Rhino… does that work any better?

thanks,

-Pascal


#10

Another reason it might not cap is that the curve is not closed. I’ve screwed this up before where there was a tiny gap or overlap in the curve/polycurve. It’s usually caused by sloppy modeling and/or not using the end-snap.


#11

I works again. I did as Pascal recommended by resetting the toolbar. Thanks to everyone who tried to help.


#12

I am having the same problem. I done the reset but the problem still there.


#13

The issue are back… And then I reset my toolbar again, but I dont want to do that once a week. Any ideas to fix this.


(Pascal Golay) #14

Hi Mathias- do you have more than one Default.RUI on your system? When it goes ‘bad’ please check the path to the currently open file in Options> Toolbar… what is that path?

-Pascal


#15

So what do we do after checking the file?


#16

I think I found out…

Go to the Extrude Straight button
Press SHIFT + Right mouse button to open Button Editor
In Button Editor, go to Command, in your case should appear something like this:

! _ExtrudeCrv _Pause
_Solid=_No

You only have to change to

! _ExtrudeCrv _Pause
_Solid=_Yes

There you go, every time you click on that button, it will extrude capped! :wink: