Rhino 5 SDK Installation Problem

I can correctly install and run Rhino 5, but the SDK installation returns an error on my PC with
Windows 10 (the returned error is: “Setup ended prematurely because of an

What can be the problem?

Do you have Visual Studio 2010 Pro installed?

1 Like

I uninstalled and re-installed visual studio 2010 Pro and now the SDK can be installed.
Thank you for your suggestion Dale!


I see this is a couple of years back but I have a similar problem. I get the same error message about ending “prematurely” as above. I have Microsoft Visual Studio 2010 Professional installed and am running on Windows 10. I have tried running the rh50sdk_5.9.40609.20145.msi file with “run as administrator” in a command prompt and also in Windows Powershell (Administrator) all with the same resulting “setup wizard ended prematurely”.

Any ideas as to what I can do?

Thanks in advance.


Does this work any better?


– Dale

Thanks very much Dale. Just in case anyone else uses this I had to be patient when first installing this .msi (as administrator of course). In fact I thought my computer had “hung”. However when the rhino install box eventually appeared the installation was then almost instant. In any case it seems to have worked. Thanks again.