Rhino 5 - Preparing Plugins for first time use

Does anyone have a list of things that when done can cause Rhino 5 to show “Preparing Plugins for First Use” on EVERY single startup?

I’m sure it is something in our Skin or our Plugin, but I’d like to fix this issue, it causes extra delays in starting our software. Its been happening for a year or two… Just hoping someone can point me in a direction.

Obviously we plan to migrate to Rhino 6 with our software but that isn’t yet something we can do.

Any help is appreciated.

Hi Jason

What plugins are you running?
If you start Rhino in safe mode I think you can explicitly allow plugins to load. This will maybe let you find what plugin is causing that message


Hi Jason - with no Rhinos running, try a right-click on the Rhino icon and choose ‘Run as administrator’, close, and reopen normally - any different?


I’m sorry, I meant to post this in Rhino Developer. The plugin in question is my own plugin for our CounterSketch software. Just hoping to find out what we might be doing to trigger the behavior in Rhino.

Launching Rhino as Admin had no effect.


@brian, is this something you can jump in on?

1 Like

My first guess is that somewhere along the line you changed the ID of the plug-in.

There’s probably a registry key somewhere like:
HKEY_LOCAL_MACHINE\Software\McNeel\Rhinoceros\5.0\Plug-ins\<old_id> that has a path to your plug-in. When that plug-in loads, it creates a
HKEY_CURRENT_USER\Software\McNeel\Rhinocerso\5.0\Plug-ins\<new_id> that has full plug-in information in it.

Because the IDs don’t match, Rhino doesn’t know to ignore the first one on subsequent loads.

Search your registry for the full path to your plug-in, I bet you’ll find it a few places.

We haven’t regularly changed the Guid in the Assembly Info for the CounterSketchServer plugin. It was incorrect for a period of time in 2016, but was corrected in 2017 and has been the same ever since.

Here are the 3 places the plugin appears in my registry, also this behaves universally among all of our users. This behavior didn’t used to happen (2+ years ago), and I was hoping to track down what I’m doing incorrectly in my code that is causing this problem.




I don’t know. I guess I’d need to remote control your computer to do more sleuthing… is there a good time this week to do that? Please direct message me to set up a time.

Sounds good, I was out this week but will be back in on Monday. I’m available anytime, just let me know. I’ll send you my contact info.