Rhino 5 and Romer Arm Digitizer Not Working

unhandled

#1

I’m trying to setup Rhino 5 to work with a CIMCORE Romer Arm portable CMM. I’ve successfully used Rhino 4 with a Faro Arm, but I’ve now upgraded to Rhino 5. The Romer Arm is listed in the digitizer connection dialog. There aren’t any errors or anything, but Rhino just does nothing when I try to use it.

Any help would be greatly appreciated.


Rhino to Romer Arm connection issues
Oldest version of WinRDS that Rhino 5 will take imput from?
(Tim Hemmelman) #2

Hi,

Earlier service releases of Rhino V5 recognized the home position as a warning when you tried to initialize a Romer and would not acknowledge it (if it was in the home position). The most recent service release of V5 corrected this. So, when you start running a command like DigCalibrate, make sure the LED in the middle of the power button is green, not red, and you should be able to overcome this with any service release of V5.

Tim


#3

Which service release, specifically, would have addressed these issues? I want to check and see what I am running. I haven’t been able to find change logs for the various updates that Rhino tells me are available periodically. I’m running SR5 now, but it seems like there may be more than one release that is called SR5.

Thank you.


(Tim Hemmelman) #4

Hi,

The fix I added was in SR5. You’re right, there were 2 releases of SR5 I think. The revision that the fix was done on was 92083. You can run TestVersionNumbers and see the revision. If that number is larger than 92083 you have the fix I mentioned. If you do have the fix, and you still can’t get you Romer running, then there’s something else happening. Is this an old(er) Romer? I mean does it use the app called WinRDS or does it use something called RDS (without the “Win” part). V5 only works with the more recent RDS app. V4 works with WinRDS.

Tim


#5

Thanks for the good information. I didn’t know about the TestVersionNumbers command. It looks like I am using revision 92072. I’ll update and see if that solves the problem.

I am using WinRDS 7.1.6. It is a Romer Infinite arm. I think it is from the 2005 time frame. Do you know if the newer RDS works with the the older arm?

Thanks again!


#6

From the Hexagon Metrology site, it looks like RDS is only applicable for the Absolute and MultiGage arms. If V5 only supports RDS, then that would mean that it does not support the Infinite Arm. Am I thinking about this correctly–I’ll have to use Rhino 4 in with WinRDS in order to get the interface with the arm working?


(Tim Hemmelman) #7

Well…that’s interesting. I think I did the original development for V5 with an Infinite arm. I just opened RDS here and took a snapshop and Infinite appears as an option.

You might ask them about it. I know the tweaks I made recently in SR5 I used an Absolute though. That was what the customer had that was having issues so I wanted to replicate the hardware as close as possible.

I guess if it came down to it, the V4 plugin ought to work in V5 win32. Since the plugins are named the same and have the same UUID it might might get a little hairy. I don’t know though, it wouldn’t be worth the pain. I seriously think you ought to see if you can get the RDS stuff from Romer.

Tim


#8

I’ve installed Rhino 4 SR9. I’m using WinRDS 7.1.6. When I try to connect, I get the following error message from Rhino. Any ideas?


#9

I think I’m making some headway. I’ve been able to get Rhino V5 to connect after installing RDS (not WinRDS). Do the arms only work with the 32-bit version?


(Tim Hemmelman) #10

Well, I think it should work with both versions. The plugin communicates with a service or something like that so I’m not sure it cares. I just looked on my computer and all of the RDS stuff is installed in Program Files (x86)\RDK which means it’s probably a win32 app (at least the interface is). I’m pretty sure I did most if not all of the development in an x64 debug build though. I’d try it out for you but I don’t have a Romer here.


(Edrichards) #11

How old is your Romer Arm? Is your Rhino 5 64-bit or 32-bit? What version of Windows are you running?

You can try copying the Romer/CimCore plugin from Rhino 4 (which is 32-bit), and substituting it for the plugin in Rhino 5. This worked for me. But I’m using Rhino 5 32-bit. You need to use 32-bit Rhino 5 to use Rhino 4 plugins.


#12

It’s been a long time. I was able to successfully complete my project. I also don’t have the Romer Arm any more. It was getting too antiquated to keep up with. However, I did manage to eventually get everything working successfully in Rhino–not easy, though.