RH6 Text Problem!

rhino
text

#1

Hello,

I have several problems with RH6 text command.
In the screenshots, there are problems with text editing.
At the first screenshot, the text is imported from AutoCAD. Maybe that’s why I cannot see any edit box on left besides just plain grey area.
If we look at the other screenshot, we can see the white text edit box on the left which was from RH5 file.

Is there any problem with AutoCAD text compatibility issue in RH6 ? In RH5 I can always see the white edit box when I click on the text.

The other issue is with the texts that are blocked.
Whenever I attempt to edit the block and align the texts to a specific location, I come up with closing the block with my new aligned text locations but following to that my text is now 20 times got larger than its previous font size.
I even tried to remove the texts first and then align it outside the block, but after I add the texts it still enlarged 20 times of its original size.
Just to let you know this block is also imported from AutoCAD.

Lastly but not least, my text command is not working right now after I type “text” to my command field.
A few days ago after my installation of RH6, I was getting used to the new type command by entering the properties first and then place the text location at the end, but now it just skips the step of placing the text location and ends up nothing happened after I specified my text properties.

I really appreciate the new RH6 performance efficiency and new additions but it might be better to have a support on this.
What is happening with the new RH6, should we have to wait for new service pack releases ?

Maybe my windows compatibility is too old to make a better performing.
If it is so I should change it by tomorrow.

My system informations as in below;

Rhino 6 SR3 2018-3-31 (Rhino 6, 6.3.18090.471, Git hash:master @ b32d93f452fce970e96deb46bfc68b075f06b290)

Windows 7 SP1 (Physical RAM: 16Gb)

GeForce GTX 675MX/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 377.19)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: NA
Driver Version: NA
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB


#2

Can I have an answer regarding this issue please ?

In this way, I can’t use RH6 at all time which will force me to use RH5 and makes it inefficient workflow.

Thanks in advance…


#3

Can you post an AutoCAD file that when imported exhibits the problem? No way to know what’s happening without a file to test.


#5

Hello Helve,

I attached the acad file in the embedded so you can check it out.
You can also see the screen recordings from my view.

I actually realized that the blocks that are made by Lisp script in AutoCAD cause this text enlargement. Maybe that is caused because the block is saved in the same file as with the lisp block.

Somehow sometimes cannot update the text even I don’t use the lisp block. In the video, I can now update it. It can be caused by the Ram maybe.

The most important issue for now is, I cannot create text in any RH6 file which I was creating before after I installed RH6 and used for several times.
I have no clue whatever is caused by…

Thanks,

Rhino 6 text-3.dwg (30.3 KB)


#6

Yes, there is definitely a problem here, but I have no idea on which end it is - I do suspect is it Rhino’s problem with the BlockEdit function though; for if you simply explode the block, the text stays correct.

However, here’s what I see that’s interesting -

  1. If I use Explode on the the block and select the different texts, they have heights varying from 1.5 to 2.2mm, but their annotation model space scale is listed as 20. (thus real heights of 30 to 44)

  2. If I undo and use BlockEdit and choose Remove Object and remove ALL the text objects at the same time and OK, they do not change size. If I then click on the text objects they show as their real size - 30 to 44 mm with a model space scale of 1.0.

  3. The problem happens when I use BlockEdit and do not remove ALL the text, but instead leave at least one text remaining inside the block… Whatever text is left in the block gets bigger. If I then explode the block with the big, bad text and check the properties, I see each text has the correct height, but the model space scale, instead of being 1, has the same value as the the text height. (i.e. if the text height is 30, the model space scale is also 30…)

I think this might have already been fixed for SR5 - if it’s the same problem:


https://mcneel.myjetbrains.com/youtrack/issue/RH-41698

So I think until we can confirm that it is fixed, you will probably need to explode your block, edit the objects and then re-define it… I don’t know who is responsible for BlockEdit - @lowell? @pascal?

As far as your other problem -

There was a thread on a similar problem caused by a Windows Update, but I can’t find it now - will continue looking… Ah, here it is:

–Mitch


(Alain Cormier) #7

Hello @boradtur666,
In your 1st video (1:05), the text edit box is hidden so you have to expand the dialog by dragging it’s bottom edge. That problem has been fixed in SR 4.


(Pascal Golay) #8

Hello - as far as I can see here, the text in your dwg no longer expands on BlockEdit, in the latest builds here…
That would be SR5, I’m not sure when that will be available as a release candidate but it should be pretty soon - you can get the earliest available by changing your setting in Options > Updates and statistics > ‘Update frequency’ to ‘Release candidate’.

-Pascal


#9

First of all, thanks for your effort for the links you’ve provided @Helvetosaur,

I checked your 1st/ 2nd /3rd trying and you are right. I was wondering why it just expands to 20 times of its size after closing the block.
I have also tried the 2nd one as that will be the only time, I can edit.

In @Sascha_Holland-Kuhn 's problem, it looks the same however I could able to use leader / dimensions.
Both “_-text” and “-text” works, thanks to showing in a different way of creating @stevebaer and @Helvetosaur

I guess my problem is also dedicated to a .NET Framework update issue. When I checked my update history in windows control panel, I found out this which is a mess… :slight_smile:

I will now try to update with @JohnM method in the fixed link he shared.

However, I confused which to install first and arranged in order below ?

@Alain after all this confusion, now I am able to create the text as you are right about the hidden text box.
Thanks a lot, now the strangeness is gone with the text creation… :slight_smile: Also I don’t need to get upset about creating the text in RH6 is got complicated as I assumed. ^^

@pascal Thanks for your information. I can saw the release of 6.4.18 for now however, I guess I need to update my windows to SP2 which I cannot reach it from either Microsoft site.
If anyone knows how to find and install SP2, it would be greatly appreciated.
My windows updates look corrupted by Net Frameworks anyway, so I think it can’t move any further to upgrade the system to SP2 as it got stuck on the .NET Framework…

Maybe its time to move Win 10, as this version 6 of Rhino will perform much better.

Thanks for all of you, for the support that you’ve provided for now.