RH6: Duplicate Egde Tool does not allow to deselect unintentional selected edges as before

Hi,

after upgrading from RH5 to RH6 I am experiencing this “bug?”:
When selecting edges along a surface I cant de-select (pressing ctrl and marking a window with the mouse going over said edge, as de-selecting generaly works) any curve I might have selected unintentionally and would have to start all over from the beginning.

Is this known or is there a solution to this?

Thanks!

Hi @phos4
Works as expected here - R6 SR19. Maybe run the SystemInfo command and post the result - it could be a plugin interfering or video drivers needing to be updated?
HTH, Jakob

Hi Jakob,
Thanks for your feedback.

This is what I get from the SystemInfo command:

Rhino 6 SR19 2019-10-22 (Rhino 6, 6.19.19295.01001, Git hash:master @ 0af62045bd35259d4c2367dbf7f9ef94ded29299)
License type: Commercial, build 2019-10-22
License details: LAN Zoo Network Node Checked Out

Windows 7 SP1 (Physical RAM: 32Gb)
Machine name: PP01

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce GTX 780 (NVidia) Memory: 3GB, Driver date: 10-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 441.12

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-24-2019
Driver Version: 26.21.14.4112
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 3 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot7RhinoPlugin (486807a0-d332-4669-8086-e0497d91acd5)\1.1.0.0\KeyShot7RhinoPlugin\Rhino 5.0\x64\KeyShot7RhinoPlugin.rhp “KeyShot7RhinoPlugin” 1.1.0.0
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot8RhinoPlugin (6c7d7caf-b4ba-406d-bfaa-8d719d8212c3)\1.5.0.0\KeyShot8RhinoPlugin\Rhino 5.0\KeyShot8RhinoPlugin.rhp “KeyShot8RhinoPlugin” 1.5.0.0
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.19.19295.1001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\1.0.0.0\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin” 1.0.0.0
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

I updated the video drivers yesterday after installing RH6.

Hi @phos4
Nothing looks out of the ordinary to me. How about single clicking + ctrl de-select - does that work? And is it both window selection (left to right) + ctrl and crossing selection (right to left) + ctrl that isn’t working?
-Jakob

Ha, thats funny, it works as normal on most other surfaces I tried after reading your reply, but on the lofted surface I would need it to work, it doesnt.

I just copy/pasted the lofted surface into RH5 and there it works as usual. Weird.

Can you post the surface here?

I could, but I think I found the issue. I did not notice that the surface was a block instance. After exploding it I can select and de-select all edges as usual. I should have noticed this as I copy/pasted into RH5 where I could not select any edge (and thought it was due the RH6>RH5 process) but then I saw it was a block instance.

Problem solved and thanks to you guys for chiming in.

Edit: To clarify, I think I did not notice it was a block instance, as in RH6 I can select the edges without exploding it, whereas in RH5 I cant select the edges and that is normally a sign of being a block instance.

@pascal Do you think it would be a good idea for Rhino 6/7 to have a replacement cue to indicate a block instance in situations like this?