Revit to Rhino Not Catching all Elements in Visible in View

Hi, I am following the tutorial for using Visible in View sample script to bring in geometry from Revit to Rhino, but I am not able to grab all the elements that are visible in Revit. I wonder if model groups has anything to do with this?
I’ve also tried to filter by category and it also does not work, and using the graphical elements way crashes rhino.
Thank you!

Do you have linked elements in the View you are trying to get?

What is the graphical elements way that is crashing? Please type SystemInfo into your Rhino command line and paste the results here. RiR version info as well (RiR ribbon>More>About)

Model Groups and their Elements are returned.

System Info Rhino 7 SR20 2022-7-12 (Rhino 7, 7.20.22193.09001, Git hash:master @ 9b19bfdb8c343dd6fa8df3514068defd72273d6f)
License type: Commercial, build 2022-07-12
License details: LAN Zoo Network Node

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP (Hosting Remote Desktop session)

Standard graphics configuration.
Primary display: Microsoft Remote Display Adapter (Microsoft) Memory: 0MB, Driver date: 6-21-2006 (M-D-Y).
> Remote Desktop display device with 16 connection(s)
- Windows Main Display using connection #0
- Secondary monitor using connection #1
Primary OpenGL: NVIDIA Quadro RTX 4000 (NVidia) Memory: 8GB, Driver date: 12-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.09
> Accelerated graphics device with 0 adapter port(s)
- There are no monitors attached to this device!

Secondary graphics devices.
Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y).
> Integrated graphics device with 0 adapter port(s)
- There are no monitors attached to this device!

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-31-2020
Driver Version: 27.21.14.6109
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2021.3.25.899\Lumion\Rhino 7.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Datasmith Rhino Exporter (d1fdc795-b334-4933-b680-088119cdc6bb)\DatasmithRhino7.rhp “Datasmith Exporter” 4.27.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.20.22193.9001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

RiR info: [Window Title]
Rhino.Inside - About

[Main Instruction]
Rhino.Inside© for Revit

[Content]
Rhino.Inside Revit: 1.8.8234.21556 (2022-07-18T11:58:32)

[Expanded Information]
Rhino: 7.20.22193.09001 (Rhino 7)
Revit: 2022.1.3 (22.1.30.34)
CLR: 4.0.30319.42000 (4.8.4400.0)
OS: Microsoft Windows NT 10.0.19044.0

[^] Hide details [Web site] [Read license] [See source code] [OK]

[Footer]
Press CTRL+C to copy this information to Clipboard

Please update your video driver

If you are still having issues after this lets disable the 3rd party plugins (lumion and datasmith)

… and running Rhino on Remote Desktop is not supported - Rhino - System Requirements.
-wim

[quote=“Japhy, post:4, topic:145777, username:Japhy”]
If you are still having issues after t
[/quote]Great Thank you both! I will try again