Resthopper - Empty Response when using specific components

I am having a weird problem.

Given this definition. CapHoles.ghx (79.7 KB)

If I run it on compute I get empty response

If I remove Cap Holes, I get the expected response
"{\"algo\":\"\",\"pointer\":null,\"values\":[{\"ParamName\":\"RH_OUT:114:GeoOut\",\"InnerTree\":{\"{ 0; }\":[{\"type\":\"Rhino.Geometry.Brep\",\"data\":\"{\\\"version\\\":10000,\\\"archive3dm\\\":70,\\\"opennurbs\\\":-1912574447,\\\"data\\\":\\\"+n8CAFsPAAD7/w ........AA=\\\"}\"}]],\"Count\":1,\"IsReadOnly\":false}]}"

This seems to be happening if Cap Holes or Cap Holes Ex are anywhere in the definition. I also get the expected response if I replace CapHoles with Brep.CapPlanarHoles() in a c# script component.

Just interested to know what is wrong here, and if any other components might have the same problem.

I’m having a similar issue.

Some RhinoCommon methods just don’t yet work in the Rhino WIP headless mode that Resthopper runs in. If I had to guess, the Cap Holes grasshopper component uses one of these WIP methods.

There’s not a comprehensive list yet, but it’s something I plan to start putting together when finals wrap up.

1 Like

I don’t believe that is the case, since as I mentioned up there, using a c# component that uses the rhinocommon function Brep.CapPlanarHoles() works perfectly well.

Maybe we should ask @stevebaer = )

Also good luck with your finals.

I’ll take a look. There was a problem with curve offset that we just fixed; maybe this is a similar problem.

1 Like

Yes, I was just reading that other post mentioning the offset problem.

I am facing the same also with another definition that uses Rhino.Geometry.Intersect.Intersection.CurveBrep() in a C# component.

@stevebaer Hi Steve, just found another component doing the same, using latest Nuget and WIP. “Discontinuity”, whatever is hooked to the P output fails to solve.

Are you running the latest WIP? I found and fixed a bug recently where GH was attempting to use ActiveDoc for many things.

I believe yes, SRC 7.0.19169.5435

Can you send me a simple gh definition that uses this component that is failing? I can trace through to see if I can repeat the problem.

@stevebaer Attached is an example
DiscontinuityProblem.ghx (216.7 KB)

I ran into something similar with the Mesh > Triangulation > Voronoi Cell component.

@SherifTarabishy The continuity component (as well as the issue I reported with Voronoi Cell) is now solving correctly on compute, thanks to a fix by @stevebaer. Please check it and report back if you have any further issues.

I don’t believe that is actually correct quite yet. We still need to release a public V7 WIP this week with the recent changes

True, I was confused with what was meant to be the expected result. Sorry for the false alarm.