Renderings looking exactly like rendered viewport


#1

Hi,

I’m wondering if it is possible to make renderings that simply looks like what you have in the rendered viewport.
I’m making lots of renderings for writing manuals at the moment, and found without adding custom lightning that the resulted rendering from the standard Rhino Render is often dark or has very strong shadows. Using the option skylight helps, but makes the picture quite washed out and makes rendering slow.
For me what’s displayed in the rendered viewport is perfect, so often I make a print screen on a big monitor of it instead of actually rendering it… Is there a better option that’s fast and gives the desired result? Thanks!


#2

If you use “-ViewCaptureToFile” you can save out a screen shot, and(with the dash) specify the resolution.


#3

I would stick at the screenshot workflow, but use a tool that allow to create high res screenshots. Jarek wrote a great free tool - MultViewCapture:

http://jarek-rhinoscripts.blogspot.de/


(Willem Derks) #4

Hi Roland,

In addition to Jim’s suggestion.
See if your workflow is more efficient if you setup a Layout page(s) with a detail in Rendered mode.
Such Layout can act as a template and be used to print as PDF /image files.

-Willem


#5

Thanks a lot, these are some great options! Wish I’d asked this question earlier…


#6

I am having the same problem as the OP. I have assigned a specific material color (using a HEX color code). In rendered viewport I am seeing the correct color. Then when I actually render (without any lighting enabled) I get a much different color. It makes sense to me that when different lighting is enabled the color of the material will be affected, because of color temperature and so on. However, with no special lighting enabled, there must be a way to get true color representation using the render tool? Any more ideas anyone?


(Andrew le Bihan) #7

Could we see a couple of images showing us what you are seeing? Viewport capture and render.


#8

Hi andy,

Thanks for the reply. I was mistaken, neither the screen capture or the rendering have exactly the right color. The Screen capture is very close though. Here are three images. The first was rendered, its HEX color code is 015B73. The second image is a screen capture, its color code is 013F4E. The third is a MS paint sketch showing the target color (HEX code 014456).

thanks,

-mike



(Andrew le Bihan) #9

Try turning off “Enable diffuse lighting” in the advanced material settings - does that work for you?


#10

Thanks for the idea andy!
I tried that, I got a very interesting result. When I rendered the image with diffused lighting disabled the color is a little different but still too light. However, the screen capture is now the correct color! So we are on the right track. Now the question is why is there such a discrepancy between the rendered image and the screen capture.
thanks,

-mike


(Andrew le Bihan) #11

The way that renderers work is really very much like Voodoo. What is actually contributing to the color may be a combination of things. The only way I could really tell is if I had the model and could actually repeat it in the debugger.


#12

Haha, I’m starting to realize that. If you would have a look at it for me I can send it?
Thanks Andy,

-mike


(Andrew le Bihan) #13

Mike

Send the model to me at andy@mcneel.com - please make sure you include all bitmaps too.

  • Andy

#14

Hey andy,

Just confirming whether you received my email with the model? We’ve been having email problems lately so I thought I should check.

-mike


(Andrew le Bihan) #15

Sorry - yes, I got it. The problem is that you have changed the “Ambient” term in the renderer settings dialog. This is adding a little bit of brightness to every color in your scene when rendering.

Set ambient back to black and everything will render fine.