Rendering using the Farm?

When sending a render to the Rhino render farm, the trees do not show up. I am unsure whether there are more elements that do not work as have not tested.
Is there a way to use farm rendering successfully with projects created using planting within Lands Design?

Hi,
there is an option in Lands to configure the folder where temporary texture files will be created so that you can use a network folder accessible by all computers in the farm. May be this could help.
If not, have you tried to uncheck the “Generate very detailed plants for the render” in the Document options (under Lands > Render). Does it make any difference?

Thanks Albert, problem solved.
Wasn’t aware of the temporary textures folder location.

Great stuff

This appears to have stopped working again?
Just rendering a basic project with the temporary texture folder location set (on the shared drive that all farm computers access).
Has there been a recent update that might have stopped this working?

Hi, nothing changed in this part of the program, it should keep working. What are the symptoms?
By now, make sure the computer launching the render has write permissions on that folder.

Hi @albert
Still not getting plants when sending a render to the Flamingo nXt farm.
I have ensured that there is a Temporary texture folder available, and this is being populated with textures required for the plants in a model, but when rendering, no plants are appearing on the finished image.

The folder was created by myself, so full write permissions are granted.
Do all machines on the farm need to have Lands installed?
Also, the ‘Generate very detailed plants in render’ option is not visible… See image attached.

Hi,
no, there is no need to have Lands on each machine.
The “Generate very detailed plants in render” is in “Lands Design > Render” but under document properties, not Rhino options. Cause you are rendering using Flamingo, try to uncheck the “use Flamingo nXt plants” option. This way, Lands is going to generate the plants instead of Flamingo. I suspect that Flamingo could require that the .ArPlantX files be present on all render machines (but I’m not sure).

Hi @albert, a little puzzled.
Clicking on the Lands Design menu and Options brings up the following window with tab for Render settings…
Is this where you mean? I dont see a Lands Design>Render option under the Document Properties section of the Options dialogue.


It’s a bit tricky. Lands Design will not appear under Document Properties until Land information (plants, terrains, etc.) is added to the document.

The Lands Design tabs under Document Properties are the same you see in the Lands Edit Panel when no objects are selected:

OK, so I marked this as solved a little prematurely and it appears to be a little inconsistent as I am currently working on a new project and un-selecting the ‘Use Flamingo Plants’ option but still not seeing plants within farm renders.
Currently it seems to have stopped working again.
Lands did prompt me to download the latest http://s3.amazonaws.com/lands/download/lands_nxt_plants_update.msi file

@albert
So the Farm rendering is not functioning.
I have tried with both Flamingo plants ticked and not ticked with no luck.
The shared temporary textures folder is set in a location available to all Farm workstations.